summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-09-07 10:45:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-09-07 10:52:59 -0500
commit131d5f0724433daa68a522847b155af8b7d86d9c (patch)
tree06ef1b9004e9dd8a7a5131b85b1f59c5c55c7489 /app-crypt
parentsci-physics/espresso: version bump (diff)
downloadgentoo-131d5f0724433daa68a522847b155af8b7d86d9c.tar.gz
gentoo-131d5f0724433daa68a522847b155af8b7d86d9c.tar.bz2
gentoo-131d5f0724433daa68a522847b155af8b7d86d9c.zip
app-crypt/acme: 0.27.1 bump
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-0.27.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 2267a1783777..5e8c0a2ec111 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,3 +1,4 @@
DIST certbot-0.24.0.tar.gz 1149694 BLAKE2B 7c57d59ced97de77e0f98eb11a2bba418ee81ba0eb4506ebc010cb0060c92820617ba2a3464dd398bfec6dc86f4c2dc8e22461d76ae51ccfbb97afab3bbb3681 SHA512 b067da7eea54deb72ff4b516382cbe480ffebcb378489a2b0c52955f7399401d936d8d6587d88473d6f4fa9e864de94514941bde9727a5babbf2d6211ea61b20
DIST certbot-0.25.1.tar.gz 1160526 BLAKE2B 2dd2196c5986d5f5fe59f711589b6c3393d9c4183febb7048eab0b85e033f81d5c7ff12d7fea3aa69585308f5a4984143e431047fee73b42b16bd49e1cd2d14f SHA512 6395baa33acb4cf9e953294ddb07694ffa1e76424e12114db8df0f64fb3f1872c3145b02d853c139183b2b708d40d236f91d356eb9ecca447f577bd725fee6e5
DIST certbot-0.26.0.tar.gz 1236499 BLAKE2B ea276f8b0fd4c7c6ce59acdcd3829d45d06ee31ac317bd846083da8ab105ae9357eaafd81992e1493c4965a95a70ee71f2d41875ca7e8c0613cbe44eeb3dffa5 SHA512 19f689d5b8724c6e7aa1539808b1b60913ad0f4a9272ebf6f40115028cef3cb49d9416239e104f125ed549c15e2a032935d0d2da1866548d0a177ef70608dce1
+DIST certbot-0.27.1.tar.gz 1240538 BLAKE2B 3d03acc8465c5d44de99ffbee67bd75fbd7d6e5d1cb1d1a6551d14c64dd699bbd91deaf3398ea3a7c2eeb8c353650e6a06cf64c88533f4270f05d1f3381843cf SHA512 ce4edd1088e9abba89f026953e42f782c6e3ef41b11123d7faf8f1e4c230b2be5107ad70b7c6d515b6ce3d06a65ae132a37d4e41fd35f728a17ba94bb09ebb00
diff --git a/app-crypt/acme/acme-0.27.1.ebuild b/app-crypt/acme/acme-0.27.1.ebuild
new file mode 100644
index 000000000000..7c82dc6d67c0
--- /dev/null
+++ b/app-crypt/acme/acme-0.27.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.0.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ nosetests -w ${PN} || die
+}