summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-01-07 01:02:47 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-01-07 01:09:24 -0600
commit1f7ce7f0e6edb23abdae8e6490358431f82f7459 (patch)
treee4737febe56edd42faa55eb65875b4edc0c0802b /app-crypt
parentdev-ruby/i18n: add 1.8.7 (diff)
downloadgentoo-1f7ce7f0e6edb23abdae8e6490358431f82f7459.tar.gz
gentoo-1f7ce7f0e6edb23abdae8e6490358431f82f7459.tar.bz2
gentoo-1f7ce7f0e6edb23abdae8e6490358431f82f7459.zip
app-crypt/acme: 1.11.0 bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-1.11.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 653ac5b25cb4..a11dafe83f7e 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.10.1.tar.gz 1416402 BLAKE2B e00ba6bf69dbf4bc91be325d4c9ba470214aeef18b4ad4ac5efbf7d077ffa9498e9cff2eff00045bc1024930f95ec56e1773c3a193a982b393caf7ee19f8ccc0 SHA512 332e92dd7d91b9774e55ef8d2c0217a57167a26d1e86d36196fc601b4abb23f40033f94112c4b4bff5f8bc54e1e32ecd68b1f01e7d67bc4fd8f7dd98ce0362cc
+DIST certbot-1.11.0.tar.gz 1419116 BLAKE2B 4749dcd897822d4e1981ef57334a493e7b729205f3ae808893ed4cab682b74c8779893378fa5cd2651b4ef681518c5aac751514104b64adfd7a17435946c46b7 SHA512 b744e44e8a7981d7b28064a2b7b5d1f47ac1ea465fa350b4f849004f38e6b3966e3118e5ebd8c1c83b9a4a065c31005c0e2cb33f75a0b04125fbe2ac17312a24
DIST certbot-1.9.0.tar.gz 1425703 BLAKE2B 9bf78824649870b3e1fc3175aae551cbfaa675a8930a89f35ba2330647d86798e4fc43011c617be2d278ab20c43dd05b02e8e61956dd7f9d10d444181874346e SHA512 098d8c077f5760c1f40f7d673820488ad7643c8b9c12561a58921cd95f60ae76515cefc19f822747f3385a68eba6f49fe5484b20142994ef67a26b0b16293ce8
diff --git a/app-crypt/acme/acme-1.11.0.ebuild b/app-crypt/acme/acme-1.11.0.ebuild
new file mode 100644
index 000000000000..39bf50ccd8ac
--- /dev/null
+++ b/app-crypt/acme/acme-1.11.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+ distutils-r1_src_compile
+ if use doc ; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests -w ${PN} || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}