summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-08 23:48:24 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-08 23:48:24 +0200
commit31c98a4e39629ad571736ff03fd1b13a32596cb5 (patch)
treef634c1accb76f455a9eb440878eab4cb971ce091 /app-crypt
parentdev-db/etcd: Version bump to 3.2.7 (diff)
downloadgentoo-31c98a4e39629ad571736ff03fd1b13a32596cb5.tar.gz
gentoo-31c98a4e39629ad571736ff03fd1b13a32596cb5.tar.bz2
gentoo-31c98a4e39629ad571736ff03fd1b13a32596cb5.zip
app-crypt/yubikey-manager-qt: Version bump to 0.3.1
Package-Manager: Portage-2.3.8, Repoman-2.3.2
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/yubikey-manager-qt/Manifest1
-rw-r--r--app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.3.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager-qt/Manifest b/app-crypt/yubikey-manager-qt/Manifest
index b36707723fd9..181fcdfa2d28 100644
--- a/app-crypt/yubikey-manager-qt/Manifest
+++ b/app-crypt/yubikey-manager-qt/Manifest
@@ -1 +1,2 @@
DIST yubikey-manager-qt-0.3.0_p20170316.tar.gz 174053 SHA256 69144073666e7ef4e8273fb1dd93b452a6091a5b9beabd2f3de41cce6d0b6668 SHA512 9280aeb242ab3e9f66b297d8cdab0b5f16bb966469932501bcfaf8d084d2db8f1c566ebdc82a4fb3f80ab196b946982f723a1cf8a36736c8dd874757b94c2472 WHIRLPOOL 6ae4c54242a83553d58cd78a24b2e99b73df004af0d8008f34a3ba635672fd2ef2b587ad3301aa1fdd3d619014704abdfe512b3d6ad9c55ae4f4f4b33aceb21b
+DIST yubikey-manager-qt-0.3.1.tar.gz 175215 SHA256 e41bcda5aae5e0f92158f591e8e584d25c9b4872475f8e4253c7a7671e94c859 SHA512 d47a6b75b50c2dca073ab74ea2d7c7c46ff86ec338f52d49afd39796cc1f3de7ddd74664b5f60f9013393b9ca24621da63d218eb3c2cb3017fefed2370b269d1 WHIRLPOOL 1d6de66f0450d72e29b9e9a2a959f4ca8ed7c8614b976115ecfb433e8b5f1795d12e6d907f73152b6bef3de6510cbcf236b2386b18a3cba2094269f78522196a
diff --git a/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.3.1.ebuild b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.3.1.ebuild
new file mode 100644
index 000000000000..660c413e887e
--- /dev/null
+++ b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit qmake-utils python-single-r1 vcs-snapshot
+
+DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt"
+SRC_URI="https://github.com/Yubico/yubikey-manager-qt/archive/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="app-crypt/yubikey-manager[${PYTHON_USEDEP}]
+ dev-python/pyotherside[${PYTHON_USEDEP}]
+ dev-qt/qtsingleapplication[qt5]
+ dev-qt/qtdeclarative:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ rm -rf vendor ykman-gui/vendor || die
+ sed -i -e "s/ykman-cli//" ${PN}.pro || die
+ sed -i -e "/qtsingleapplication.pri/d" -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" -i ykman-gui/ykman-gui.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}