summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-05 11:42:27 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-03-05 11:42:41 +0100
commit3e265661e0920d612455ca3fe2d3059db9cdeaef (patch)
treef90aff1532190b37166b0a7b7e59f90b57eee29c /app-crypt
parentkde-apps/kfile: amd64 stable wrt bug #569742 (diff)
downloadgentoo-3e265661e0920d612455ca3fe2d3059db9cdeaef.tar.gz
gentoo-3e265661e0920d612455ca3fe2d3059db9cdeaef.tar.bz2
gentoo-3e265661e0920d612455ca3fe2d3059db9cdeaef.zip
app-crypt/letsencrypt: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/letsencrypt/Manifest1
-rw-r--r--app-crypt/letsencrypt/letsencrypt-0.4.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-crypt/letsencrypt/Manifest b/app-crypt/letsencrypt/Manifest
index 8ce784e5482a..a9070132d4b4 100644
--- a/app-crypt/letsencrypt/Manifest
+++ b/app-crypt/letsencrypt/Manifest
@@ -1 +1,2 @@
DIST letsencrypt-0.4.1.tar.gz 672827 SHA256 750c4a2966ec21009e4f7d510eceb3f97f941f6c19eda8b58b7030ef8518cef9 SHA512 8b782ddf352c33c513e26bff0525932c9ab154a7a2545093be8958f851418700b449b3092fb8c4e1d45f6ededed979650c2593668a2dd1294760666702271182 WHIRLPOOL 6ba5bc2c1646880d8d24baad4311b8fd761765e7c8a2e8c5755627d31aad85634af545415098c0bbf28ef7ee9610709f7a6cf72d07ec7a11df6ef1fca6b3eb62
+DIST letsencrypt-0.4.2.tar.gz 674494 SHA256 0f55c0f292829a9c6c1da7a57860290285cfa5da8615a87b8c268a946ab656b2 SHA512 cce6a69b7903b65aa93aa794fa5353701944d6d0736393f68e3f17316116929efa864310fb7275d62c94ab30921cae694fb7c2cd13c08164344c2e3a533cd434 WHIRLPOOL 1e6a482090e92b6fafb43a74c3956be0f25c37edd90e43a240e41aba15a97ff2c881f63eba920da4b7c2b24ef0d912df739c9918c6fb7f35892646d5e20b71c0
diff --git a/app-crypt/letsencrypt/letsencrypt-0.4.2.ebuild b/app-crypt/letsencrypt/letsencrypt-0.4.2.ebuild
new file mode 100644
index 000000000000..0ef00d4fa434
--- /dev/null
+++ b/app-crypt/letsencrypt/letsencrypt-0.4.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/letsencrypt/letsencrypt.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/letsencrypt/letsencrypt https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.10.0[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pythondialog-3.2.2:python-2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -w ${PN}/tests || die
+}