summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-02-18 20:47:11 -0600
committerSam James <sam@gentoo.org>2022-02-19 05:12:51 +0000
commit5605c2f8a4c2150f0f7caa679fc615c5f9731a5a (patch)
tree1a0e5392317f64ce9a21b75d4e134c81ac0ddbc6 /app-crypt
parentdev-java/commons-daemon: respect AR (diff)
downloadgentoo-5605c2f8a4c2150f0f7caa679fc615c5f9731a5a.tar.gz
gentoo-5605c2f8a4c2150f0f7caa679fc615c5f9731a5a.tar.bz2
gentoo-5605c2f8a4c2150f0f7caa679fc615c5f9731a5a.zip
app-crypt/swtpm: Bump to fix CVE-2022-23645
Bug: https://bugs.gentoo.org/833635 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/swtpm/Manifest1
-rw-r--r--app-crypt/swtpm/swtpm-0.7.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-crypt/swtpm/Manifest b/app-crypt/swtpm/Manifest
index d968d2271484..91a7368e7a07 100644
--- a/app-crypt/swtpm/Manifest
+++ b/app-crypt/swtpm/Manifest
@@ -1,2 +1,3 @@
DIST swtpm-0.6.1.tar.gz 326488 BLAKE2B 46c53cbd4195cfc1d45ef5e56b1f78c59dcb9f859349e161f07d9933ce720ec3511343cf29236119d08162410355fc50cb5d15745c84db78d860b006812c169f SHA512 a44e36820ad61e84d62b330f3adf0c463c98438056d74c5ba30916d956e722633e0198ae87be8352a0ab909ae5a4bbc3826410d2166186c43bba067f533fec85
DIST swtpm-0.7.0.tar.gz 353641 BLAKE2B a9169affdfd09cec887667e21d4db72b7d4b489bf3ecf5e43da9ae2d59ef3f15b94627ce22ed1f6fca69f46da40293ba1ef3d129fab7de3ca32c4b12ffc51544 SHA512 32096309bf710e51d7565f013db32627423682fb2bfa9358976126102a0bf07401146bae9346af389c932c038f3d03217739375cef01a2ff10b01c7bd004b55e
+DIST swtpm-0.7.1.tar.gz 353819 BLAKE2B dcabe72fc93c9e8099b879457d7698bf16a3c1b72ff3df9c040b1b0f3a72b3a3c453405626ade745e62d0aea4449f743c8039680accc496709915f689a69395b SHA512 c6eeb79f85550f2a184fa4a1e0d2e5b110f988b6153489001b356c2c16ee332fd462abeb77ca31268e71c3dd1680596f46dcea5031fdce185314cadb6a354c2b
diff --git a/app-crypt/swtpm/swtpm-0.7.1.ebuild b/app-crypt/swtpm/swtpm-0.7.1.ebuild
new file mode 100644
index 000000000000..158c5d3d7579
--- /dev/null
+++ b/app-crypt/swtpm/swtpm-0.7.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Libtpms-based TPM emulator"
+HOMEPAGE="https://github.com/stefanberger/swtpm"
+SRC_URI="https://github.com/stefanberger/swtpm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="fuse +gnutls seccomp test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="fuse? (
+ dev-libs/glib:2
+ sys-fs/fuse:0
+ )
+ gnutls? (
+ dev-libs/libtasn1:=
+ >=net-libs/gnutls-3.1.0:=[tools,pkcs11]
+ )
+ seccomp? ( sys-libs/libseccomp )
+ acct-group/tss
+ acct-user/tss
+ dev-libs/openssl:0=
+ dev-libs/json-glib
+ dev-libs/libtpms
+ ${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}
+ test? (
+ net-misc/socat
+ dev-tcltk/expect
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.0-fix-localca-path.patch"
+ "${FILESDIR}/${PN}-0.5.0-build-sys-Remove-WError.patch"
+)
+
+src_prepare() {
+ use test || eapply "${FILESDIR}/${PN}-0.5.0-disable-test-dependencies.patch"
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-openssl \
+ --without-selinux \
+ $(use_with fuse cuse) \
+ $(use_with gnutls) \
+ $(use_with seccomp)
+}
+
+src_install() {
+ default
+ fowners -R tss:root /var/lib/swtpm-localca
+ fperms 750 /var/lib/swtpm-localca
+ keepdir /var/lib/swtpm-localca
+ find "${D}" -name '*.la' -delete || die
+}