summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-07-29 20:17:58 +0000
committerMichał Górny <mgorny@gentoo.org>2023-07-30 05:13:07 +0200
commit56c155995df9431293a7908427287288c29c61a1 (patch)
tree9b962a00c342b735784d4cea542f9cbb47b72713 /app-crypt
parentdev-python/scikit-build-core: Bump to 0.4.8 (diff)
downloadgentoo-56c155995df9431293a7908427287288c29c61a1.tar.gz
gentoo-56c155995df9431293a7908427287288c29c61a1.tar.bz2
gentoo-56c155995df9431293a7908427287288c29c61a1.zip
app-crypt/signify: Fix call to undeclared function b64_pton
Upstream PR: https://github.com/aperezdc/signify/pull/43 Closes: https://bugs.gentoo.org/894354 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32097 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/signify/files/signify-31-fix-build-clang-16.patch35
-rw-r--r--app-crypt/signify/signify-31.ebuild24
2 files changed, 52 insertions, 7 deletions
diff --git a/app-crypt/signify/files/signify-31-fix-build-clang-16.patch b/app-crypt/signify/files/signify-31-fix-build-clang-16.patch
new file mode 100644
index 000000000000..6f03d5b5340d
--- /dev/null
+++ b/app-crypt/signify/files/signify-31-fix-build-clang-16.patch
@@ -0,0 +1,35 @@
+Upstream PR: https://github.com/aperezdc/signify/pull/43
+From: Brahmajit Das <brahmajit.xyz@gmail.com>
+Date: Sat, 29 Jul 2023 20:07:48 +0000
+Subject: [PATCH] Fix build with clang 16
+
+Bug: https://bugs.gentoo.org/894354
+Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
+--- a/base64.c
++++ b/base64.c
+@@ -52,6 +52,7 @@
+
+ #include <stdlib.h>
+ #include <string.h>
++#include "base64.h"
+
+ static const char Base64[] =
+ "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/";
+--- /dev/null
++++ b/base64.h
+@@ -0,0 +1,2 @@
++int b64_pton(char const *, unsigned char *, size_t);
++int b64_ntop(unsigned char const *, size_t , char *, size_t);
+--- a/signify.c
++++ b/signify.c
+@@ -34,6 +34,7 @@
+ #include "sha2.h"
+
+ #include "crypto_api.h"
++#include "base64.h"
+ #include "signify.h"
+
+ #define SIGBYTES crypto_sign_ed25519_BYTES
+--
+2.41.0
+
diff --git a/app-crypt/signify/signify-31.ebuild b/app-crypt/signify/signify-31.ebuild
index 7f3e660468a9..294005cc7e9b 100644
--- a/app-crypt/signify/signify-31.ebuild
+++ b/app-crypt/signify/signify-31.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -16,18 +16,28 @@ SRC_URI="
verify-sig? (
https://github.com/aperezdc/${PN}/releases/download/v${PV}/SHA256.sig
-> ${P}.sha.sig
- )"
+ )
+"
LICENSE="BSD-1"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc x86"
-RDEPEND="!net-mail/signify
- >=dev-libs/libbsd-0.7"
-DEPEND="${RDEPEND}"
-BDEPEND="verify-sig? ( sec-keys/signify-keys-signify )"
+DEPEND="
+ >=dev-libs/libbsd-0.7
+"
+RDEPEND="
+ ${DEPEND}
+ !net-mail/signify
+"
+BDEPEND="
+ verify-sig? ( sec-keys/signify-keys-signify )
+"
-PATCHES=( "${FILESDIR}"/${PN}-30-man_compress.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-30-man_compress.patch
+ "${FILESDIR}"/${PN}-31-fix-build-clang-16.patch
+)
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/signify-keys/${PN}-30.pub"