summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-11 22:15:28 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-11 22:15:28 +0200
commit639e72a3c2bcbdc04fac4978b01951acd3f6d893 (patch)
tree92ab4985d0037a11c73b8d8bed7b852ad5c352e3 /app-crypt
parentapp-emulation/winetricks: x86 stable (bug #781179) (diff)
downloadgentoo-639e72a3c2bcbdc04fac4978b01951acd3f6d893.tar.gz
gentoo-639e72a3c2bcbdc04fac4978b01951acd3f6d893.tar.bz2
gentoo-639e72a3c2bcbdc04fac4978b01951acd3f6d893.zip
app-crypt/scute: Bump to 1.7.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/scute/Manifest2
-rw-r--r--app-crypt/scute/scute-1.7.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/scute/Manifest b/app-crypt/scute/Manifest
index 9e0dd64dce8b..faa2fab1dbf7 100644
--- a/app-crypt/scute/Manifest
+++ b/app-crypt/scute/Manifest
@@ -1,2 +1,4 @@
DIST scute-1.6.0-manual-eps-images.tar.xz 236968 BLAKE2B 27b834f95dbd7a00193b55a8ff55c34e9bc65b31d9de09199b6bad62d2718d247717a461b58ccd55acb0331f6d980ac01cd62de7729ddafd368ebf08cbe2edde SHA512 dc7d622207f1979e5b527e3213f191f14322af9745462bf0803563711f0cb4b4c03f920742ca425987e1c8f632a05772dd5cc2f1d5afec2616ca93de74402deb
DIST scute-1.6.0.tar.bz2 1008407 BLAKE2B 3ef4e1870c52007fc7f838f31c4102aeee23e6e59fe13ad1990ed9c7eb4eda948a698bea475daa2d965d1c23f65940aae9b4ded518cb9268af4ec442414932db SHA512 dd9f9d9da7979a8f4766af34b0d6d6fea63d43feb4d7e5e82cca25c792d5ec87f6d9604e7eafa822ddddfaa8541bff616c0c19c73cf3f12b21ffa1c3128bcb4c
+DIST scute-1.7.0-manual-eps-images.tar.xz 236940 BLAKE2B 499207d9059bd4505f426b75f292e66755919d3e4e0d04d2f2420e2e0ceafa14ee47f0a3d7fd2846478dd0878eb01a776582a8299014728f4508a982fec36a28 SHA512 d227111456e664a295ee466dc990364423734170bc82d9a9d38ff72e79abca84775f164c2cf0dd893b9dfb63ff5035334f1740f80601a04dbc9fcb0877f50da7
+DIST scute-1.7.0.tar.bz2 851177 BLAKE2B 9a459fc07c53e44d6b194f0f7786644dae7c37402f69cc511ed7e6cc387236cfe01b13400779a90a123461a28e69629abc260f0fad9c302a9b630e23cb8b4293 SHA512 d58771a8e45632f468b60ec2255f84ef5f2f4cc5e11cf8b0fcd0cec60cc8fe0c49bdd523e855998d5aa6f126138981b2316ee825cf33ec14e723f158e36283d3
diff --git a/app-crypt/scute/scute-1.7.0.ebuild b/app-crypt/scute/scute-1.7.0.ebuild
new file mode 100644
index 000000000000..ef227673fab2
--- /dev/null
+++ b/app-crypt/scute/scute-1.7.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
+HOMEPAGE="http://www.scute.org/"
+SRC_URI="
+ mirror://gnupg/scute/${P}.tar.bz2
+ https://dev.gentoo.org/~soap/distfiles/${P}-manual-eps-images.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# configure script try to check the version of gpgsm and gpg-agent when
+# non-crosscompiling so we need to have them as build-time dependency as
+# well as runtime. Require a version of gnupg that is patched to have
+# gpgsm-gencert.sh working (as that's what the documentation describe).
+BDEPEND="
+ >=app-crypt/pinentry-0.7.0
+ >=app-crypt/gnupg-2.0.17-r1[smartcard]"
+DEPEND="
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libassuan-2.0.0"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}"
+BDEPEND+="
+ sys-apps/texinfo"
+
+src_unpack() {
+ default
+
+ # have to use pregenerated EPS files required for the texinfo documentation,
+ # due to bug 664236 preventing even converting *to* eps.
+ mv scute-eps/*.eps "${S}"/doc/ || die
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/pkcs11 \
+ --with-libgpg-error-prefix="${ESYSROOT}"/usr \
+ --with-libassuan-prefix="${ESYSROOT}"/usr
+}
+
+src_install() {
+ default
+
+ # only building plugins
+ find "${ED}" -name '*.la' -delete || die
+}