summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-12 00:32:01 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-12 00:32:28 +0200
commit66c007173e40d0e4dcd3a92f85489fe03c3d339e (patch)
tree2ebd42226a89e623891cb49d45606e1bf38aa9cf /app-crypt
parentdev-python/python-augeas: enable py3.10 and disable py3.7 (diff)
downloadgentoo-66c007173e40d0e4dcd3a92f85489fe03c3d339e.tar.gz
gentoo-66c007173e40d0e4dcd3a92f85489fe03c3d339e.tar.bz2
gentoo-66c007173e40d0e4dcd3a92f85489fe03c3d339e.zip
app-crypt/certbot-apache: enable py3.10 and tests
Closes: https://bugs.gentoo.org/795540 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild
index 7f0e325d33df..b46b10fa3536 100644
--- a/app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-1.18.0.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{3_7,3_8,3_9})
+
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
if [[ ${PV} == 9999* ]]; then
@@ -28,3 +29,5 @@ RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
dev-python/python-augeas[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest