summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2022-01-11 11:42:00 +0100
committerSam James <sam@gentoo.org>2022-01-13 05:49:18 +0000
commit6b33c454fa3ca9eb1aaddc0ecb20c4ae24133cbf (patch)
treeadd4b4368def072a103f9bcd85c2a85c0fa4c224 /app-crypt
parentdev-util/apitrace: fix build with glibc-2.34 (diff)
downloadgentoo-6b33c454fa3ca9eb1aaddc0ecb20c4ae24133cbf.tar.gz
gentoo-6b33c454fa3ca9eb1aaddc0ecb20c4ae24133cbf.tar.bz2
gentoo-6b33c454fa3ca9eb1aaddc0ecb20c4ae24133cbf.zip
app-crypt/adcli: fix musl linking bug
apply a patch which has been merged upstream Closes: https://bugs.gentoo.org/830325 Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/23739 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/adcli/adcli-0.9.1-r1.ebuild3
-rw-r--r--app-crypt/adcli/files/adcli-0.9.1-library-include-endian.h-for-le32toh.patch28
2 files changed, 30 insertions, 1 deletions
diff --git a/app-crypt/adcli/adcli-0.9.1-r1.ebuild b/app-crypt/adcli/adcli-0.9.1-r1.ebuild
index 5224249d5001..f353d5f60544 100644
--- a/app-crypt/adcli/adcli-0.9.1-r1.ebuild
+++ b/app-crypt/adcli/adcli-0.9.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -27,6 +27,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-glibc-2.34-resolv.patch
+ "${FILESDIR}"/${P}-library-include-endian.h-for-le32toh.patch
)
src_prepare() {
diff --git a/app-crypt/adcli/files/adcli-0.9.1-library-include-endian.h-for-le32toh.patch b/app-crypt/adcli/files/adcli-0.9.1-library-include-endian.h-for-le32toh.patch
new file mode 100644
index 000000000000..246ccd990f12
--- /dev/null
+++ b/app-crypt/adcli/files/adcli-0.9.1-library-include-endian.h-for-le32toh.patch
@@ -0,0 +1,28 @@
+From dfbaa1b7f7cde281e23464ceb24699d4686651ab Mon Sep 17 00:00:00 2001
+From: Henning Schild <henning@hennsch.de>
+Date: Tue, 11 Jan 2022 08:22:55 +0100
+Subject: [PATCH] library: include endian.h for le32toh
+
+upstream commit 938065a751c0876eb837a27f8c1443fc7d0d2551
+
+linking against musl libc we need to include that specifically, actually
+also according to "man 3 endian".
+---
+ library/adutil.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/library/adutil.c b/library/adutil.c
+index 9b0c47f3b7e9..4bb06a3a7588 100644
+--- a/library/adutil.c
++++ b/library/adutil.c
+@@ -29,6 +29,7 @@
+
+ #include <assert.h>
+ #include <ctype.h>
++#include <endian.h>
+ #include <errno.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+--
+2.34.1
+