summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2024-03-07 19:57:51 -0600
committerSam James <sam@gentoo.org>2024-04-16 03:27:33 +0100
commit6f08de91f6e8ba84835173b53fbd33720a302a1b (patch)
tree7a975402dfcdd3da33f84f751282291d43ed33b2 /app-crypt
parentnet-misc/wget: fix build w/ USE="-debug libproxy" (diff)
downloadgentoo-6f08de91f6e8ba84835173b53fbd33720a302a1b.tar.gz
gentoo-6f08de91f6e8ba84835173b53fbd33720a302a1b.tar.bz2
gentoo-6f08de91f6e8ba84835173b53fbd33720a302a1b.zip
app-crypt/tpm2-tools: Exclude bash completion for tpm2_tr_encode
Closes: https://bugs.gentoo.org/925860 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-5.6-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-5.6-r1.ebuild b/app-crypt/tpm2-tools/tpm2-tools-5.6-r1.ebuild
index 04fb5536f1f5..216cca435e9d 100644
--- a/app-crypt/tpm2-tools/tpm2-tools-5.6-r1.ebuild
+++ b/app-crypt/tpm2-tools/tpm2-tools-5.6-r1.ebuild
@@ -73,7 +73,8 @@ src_install() {
local utils=( "${ED}"/usr/bin/tpm2_* )
utils=("${utils[@]##*/}")
# these utiltites don't have bash completions
- local nobashcomp=( tpm2_encodeobject tpm2_getpolicydigest tpm2_sessionconfig )
+ local nobashcomp=( tpm2_encodeobject tpm2_getpolicydigest\
+ tpm2_sessionconfig tpm2_tr_encode)
mapfile -d $'\0' -t utils < <(printf '%s\0' "${utils[@]}" | grep -Ezvw "${nobashcomp[@]/#/-e}")
bashcomp_alias tpm2 "${utils[@]}"
}