summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-29 14:17:51 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-29 14:17:51 +0100
commit724947bb0fa0e99d6a4b51c5ca293b5aa33e6e91 (patch)
treebfb0f43e9dee628eb561781a5e21c65089283e9c /app-crypt
parentapp-crypt/scute: Take over maintainership (diff)
downloadgentoo-724947bb0fa0e99d6a4b51c5ca293b5aa33e6e91.tar.gz
gentoo-724947bb0fa0e99d6a4b51c5ca293b5aa33e6e91.tar.bz2
gentoo-724947bb0fa0e99d6a4b51c5ca293b5aa33e6e91.zip
app-crypt/scute: Bump to 1.6.0
Closes: https://bugs.gentoo.org/696704 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/scute/Manifest2
-rw-r--r--app-crypt/scute/scute-1.6.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/scute/Manifest b/app-crypt/scute/Manifest
index 3881b06be2f0..87f5c1b53f6f 100644
--- a/app-crypt/scute/Manifest
+++ b/app-crypt/scute/Manifest
@@ -1 +1,3 @@
DIST scute-1.5.0.tar.bz2 991598 BLAKE2B 3a5fdcb5c7d1ae50ce5aa508388e768c6f59c366d81d91312a60ff319b3ad7e01b3bfe5986ee880980b0f5371402c21bd8da963977459d3b90fbd607e64ea2ae SHA512 ad1dbdba5681a92696c851eca7e2bfb61f7bf84f5e02728efc1f72cd25c4ee2dc18fe975e2903d1a85c635d16be1e2085ff2305827b48d80e18c9354e555b39a
+DIST scute-1.6.0-manual-eps-images.tar.xz 236968 BLAKE2B 27b834f95dbd7a00193b55a8ff55c34e9bc65b31d9de09199b6bad62d2718d247717a461b58ccd55acb0331f6d980ac01cd62de7729ddafd368ebf08cbe2edde SHA512 dc7d622207f1979e5b527e3213f191f14322af9745462bf0803563711f0cb4b4c03f920742ca425987e1c8f632a05772dd5cc2f1d5afec2616ca93de74402deb
+DIST scute-1.6.0.tar.bz2 1008407 BLAKE2B 3ef4e1870c52007fc7f838f31c4102aeee23e6e59fe13ad1990ed9c7eb4eda948a698bea475daa2d965d1c23f65940aae9b4ded518cb9268af4ec442414932db SHA512 dd9f9d9da7979a8f4766af34b0d6d6fea63d43feb4d7e5e82cca25c792d5ec87f6d9604e7eafa822ddddfaa8541bff616c0c19c73cf3f12b21ffa1c3128bcb4c
diff --git a/app-crypt/scute/scute-1.6.0.ebuild b/app-crypt/scute/scute-1.6.0.ebuild
new file mode 100644
index 000000000000..597dcf357385
--- /dev/null
+++ b/app-crypt/scute/scute-1.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
+HOMEPAGE="http://www.scute.org/"
+SRC_URI="
+ mirror://gnupg/scute/${P}.tar.bz2
+ https://dev.gentoo.org/~soap/distfiles/${P}-manual-eps-images.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# configure script try to check the version of gpgsm and gpg-agent when
+# non-crosscompiling so we need to have them as build-time dependency as
+# well as runtime. Require a version of gnupg that is patched to have
+# gpgsm-gencert.sh working (as that's what the documentation describe).
+BDEPEND="
+ >=app-crypt/pinentry-0.7.0
+ >=app-crypt/gnupg-2.0.17-r1[smartcard]"
+DEPEND="
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libassuan-2.0.0"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}"
+BDEPEND+="
+ sys-apps/texinfo"
+
+src_unpack() {
+ default
+
+ # have to use pregenerated EPS files required for the texinfo documentation,
+ # due to bug 664236 preventing even converting *to* eps.
+ mv scute-eps/*.eps "${S}"/doc/manual/ || die
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/pkcs11 \
+ --with-libgpg-error-prefix="${ESYSROOT}"/usr \
+ --with-libassuan-prefix="${ESYSROOT}"/usr
+}
+
+src_install() {
+ default
+
+ # only building plugins
+ find "${D}" -name '*.la' -delete || die
+}