summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-05-04 19:56:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-05-04 19:58:37 -0500
commit7a0127a82f495d27d19bfea7cf5423339c2fc550 (patch)
tree565b5a48e7eca31799ca0422abb665a66042c23b /app-crypt
parentapp-crypt/acme: 1.27.0 bump (diff)
downloadgentoo-7a0127a82f495d27d19bfea7cf5423339c2fc550.tar.gz
gentoo-7a0127a82f495d27d19bfea7cf5423339c2fc550.tar.bz2
gentoo-7a0127a82f495d27d19bfea7cf5423339c2fc550.zip
app-crypt/certbot: 1.27.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-1.27.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 91c8287f90ca..0e685d990265 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.25.0.tar.gz 1362891 BLAKE2B c109f7777328dcaa2760b524a005f648f8695518a3a052a1d3ff20367f0b704c2a15c912ede091ef6f0f2faf2838caaa74d3bdac6deeb4cc069e6ca16cfb26a7 SHA512 e32cac530d7854cb626aed6d7bac7b4482b7c3634d94fbabd6fa767f9c1268ed3baed0c945362df247e4fc7d51147e5561825850d52c1a8f11b3a1fb2827bd4a
DIST certbot-1.26.0.tar.gz 1364070 BLAKE2B f9b13df8fb424e579293280202b71756c37a3ec7f986da38a5fd318d00ab7e2ed89223c62a20448ad30271783bb3c44db11a0ce4afebced9f1e9ca4e4c6de3f2 SHA512 bd27cb0a0ef6fc143a3d0dcf5d530d336b93a24d7010e6427c25614befb815f33076b4a3043bb247cafdfad17b8714a19ead43257c64f4fd72ac99f02cb07cde
+DIST certbot-1.27.0.tar.gz 1366469 BLAKE2B e9ec47520e027a9d348e861ea7d070eff4857301be0d42be6965e4159d85ef60866aa70de76edd5e68b0d40d9544075aa28e9aa07a8e04dfbf3e1a7dd77fd1de SHA512 5db7836ae2eda27c088476c149e736ce7f41b85d871cf563c69e021dd8af2d64ed85c1482049edf0dffe6fd0c9591d66be3e22fbf617068600e12691c4802e5e
diff --git a/app-crypt/certbot/certbot-1.27.0.ebuild b/app-crypt/certbot/certbot-1.27.0.ebuild
new file mode 100644
index 000000000000..0040de76755a
--- /dev/null
+++ b/app-crypt/certbot/certbot-1.27.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+S=${WORKDIR}/${P}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest