summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-12-09 10:02:47 -0600
committerSam James <sam@gentoo.org>2022-12-21 23:35:34 +0000
commit7a09f02ad246b55f6058494f99967381ea0e6397 (patch)
tree417a54cc24f3a2970a1e1be20a3d71bc56a83f21 /app-crypt
parentapp-crypt/tpm2-tools: add 5.4 (diff)
downloadgentoo-7a09f02ad246b55f6058494f99967381ea0e6397.tar.gz
gentoo-7a09f02ad246b55f6058494f99967381ea0e6397.tar.bz2
gentoo-7a09f02ad246b55f6058494f99967381ea0e6397.zip
app-crypt/tpm2-abrmd: add 3.0.0
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28615 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm2-abrmd/Manifest1
-rw-r--r--app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/tpm2-abrmd/Manifest b/app-crypt/tpm2-abrmd/Manifest
index ab9d8884a85b..6d4d9df9473c 100644
--- a/app-crypt/tpm2-abrmd/Manifest
+++ b/app-crypt/tpm2-abrmd/Manifest
@@ -1 +1,2 @@
DIST tpm2-abrmd-2.4.1.tar.gz 577259 BLAKE2B 7d97e1069a171f3693fb11b8e2ce0243993f4352aae9fd691bfbf1b8fcef8615b79957f8f662ac00fe59bf7e3830d8abb79c67790f7be1cd3140fd1c7b1ed560 SHA512 0335285678cfceca4f185981ded90d213ff796cadddc9b5d6dbf2db533f81023a0f1089bbd8a8017bccb95190889be23b24d38a176d3368d221479aff4ff7d6c
+DIST tpm2-abrmd-3.0.0.tar.gz 576822 BLAKE2B cdcb677a2dec59cdc454b98793bb0784ba3403c276b618cd37c5748ab1d883ee8f3f69c0ae95c7bf262e2e993dcc0b12ae39010de12c6c211fe3de8c21515160 SHA512 65a39cd0518dfbcbd5835ac6c6628444d412e36471702f2cd1f1077d788330a477778e6403899ea2fa0497b643e5db9ca3e746845492eff78c4c78d8dd8f9e7d
diff --git a/app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0.ebuild b/app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0.ebuild
new file mode 100644
index 000000000000..05a6ccde2828
--- /dev/null
+++ b/app-crypt/tpm2-abrmd/tpm2-abrmd-3.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="TPM2 Access Broker & Resource Manager"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-abrmd"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="acct-group/tss
+ acct-user/tss
+ sys-apps/dbus
+ dev-libs/glib:=
+ app-crypt/tpm2-tss:="
+DEPEND="${RDEPEND}
+ test? (
+ app-crypt/swtpm
+ >=app-crypt/tpm2-tss-3.0.0:=
+ dev-util/cmocka
+ )"
+BDEPEND="virtual/pkgconfig
+ dev-util/gdbus-codegen"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # tests fail with LTO enabbled. See bug 865275
+ filter-lto
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test unit) \
+ $(use_enable test integration) \
+ --disable-defaultflags \
+ --with-dbuspolicydir="${EPREFIX}/etc/dbus-1/system.d" \
+ --with-systemdpresetdir="$(systemd_get_systemunitdir)/../system-preset" \
+ --with-systemdpresetdisable \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ einfo "As of tpm2-abrmd 3.0.0, users must be in the tss group"
+ einfo "To access the TPM"
+}