summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-19 00:43:54 +0000
committerSam James <sam@gentoo.org>2023-03-19 00:43:54 +0000
commit7b89e73e3f0497297ab49f7693e50c683627b63e (patch)
treeb39fa9a5a32ed17386c775267dd02670fff6ec52 /app-crypt
parentnet-misc/lldpd: fix configure w/ clang 16 (diff)
downloadgentoo-7b89e73e3f0497297ab49f7693e50c683627b63e.tar.gz
gentoo-7b89e73e3f0497297ab49f7693e50c683627b63e.tar.bz2
gentoo-7b89e73e3f0497297ab49f7693e50c683627b63e.zip
app-crypt/ccrypt: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/900130 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/ccrypt/ccrypt-1.11-r4.ebuild (renamed from app-crypt/ccrypt/ccrypt-1.11-r3.ebuild)23
-rw-r--r--app-crypt/ccrypt/files/ccrypt-1.11-refresh-macro-clang16.patch64
2 files changed, 83 insertions, 4 deletions
diff --git a/app-crypt/ccrypt/ccrypt-1.11-r3.ebuild b/app-crypt/ccrypt/ccrypt-1.11-r4.ebuild
index dc921dadfc0a..a8bd812cb08c 100644
--- a/app-crypt/ccrypt/ccrypt-1.11-r3.ebuild
+++ b/app-crypt/ccrypt/ccrypt-1.11-r4.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
+
+inherit autotools
DESCRIPTION="Encryption and decryption"
HOMEPAGE="https://sourceforge.net/projects/ccrypt/"
@@ -13,8 +15,21 @@ KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="emacs"
RDEPEND="virtual/libcrypt:="
-DEPEND="${RDEPEND}
- emacs? ( >=app-editors/emacs-23.1:* )"
+DEPEND="
+ ${RDEPEND}
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.11-refresh-macro-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ # Clang 16 patch
+ eautoreconf
+}
src_configure() {
econf \
diff --git a/app-crypt/ccrypt/files/ccrypt-1.11-refresh-macro-clang16.patch b/app-crypt/ccrypt/files/ccrypt-1.11-refresh-macro-clang16.patch
new file mode 100644
index 000000000000..f610a1c38065
--- /dev/null
+++ b/app-crypt/ccrypt/files/ccrypt-1.11-refresh-macro-clang16.patch
@@ -0,0 +1,64 @@
+https://bugs.gentoo.org/900130
+
+Refresh macro from gettext.
+--- a/m4/intdiv0.m4
++++ b/m4/intdiv0.m4
+@@ -1,5 +1,5 @@
+-# intdiv0.m4 serial 6 (gettext-0.18.2)
+-dnl Copyright (C) 2002, 2007-2008, 2010-2016 Free Software Foundation, Inc.
++# intdiv0.m4 serial 9 (gettext-0.21.1)
++dnl Copyright (C) 2002, 2007-2008, 2010-2020 Free Software Foundation, Inc.
+ dnl This file is free software; the Free Software Foundation
+ dnl gives unlimited permission to copy and/or distribute it,
+ dnl with or without modifications, as long as this notice is preserved.
+@@ -12,7 +12,7 @@ AC_DEFUN([gt_INTDIV0],
+ AC_REQUIRE([AC_CANONICAL_HOST])dnl
+
+ AC_CACHE_CHECK([whether integer division by zero raises SIGFPE],
+- gt_cv_int_divbyzero_sigfpe,
++ [gt_cv_int_divbyzero_sigfpe],
+ [
+ gt_cv_int_divbyzero_sigfpe=
+ changequote(,)dnl
+@@ -31,8 +31,11 @@ changequote([,])dnl
+ if test -z "$gt_cv_int_divbyzero_sigfpe"; then
+ AC_RUN_IFELSE(
+ [AC_LANG_SOURCE([[
+-#include <stdlib.h>
++#include <stdlib.h> /* for exit() */
+ #include <signal.h>
++#if !(defined _WIN32 && !defined __CYGWIN__)
++#include <unistd.h> /* for _exit() */
++#endif
+
+ static void
+ sigfpe_handler (int sig)
+@@ -44,7 +47,7 @@ sigfpe_handler (int sig)
+ int x = 1;
+ int y = 0;
+ int z;
+-int nan;
++int inan;
+
+ int main ()
+ {
+@@ -59,7 +62,7 @@ int main ()
+ #endif
+
+ z = x / y;
+- nan = y / y;
++ inan = y / y;
+ exit (2);
+ }
+ ]])],
+@@ -79,8 +82,8 @@ changequote([,])dnl
+ fi
+ ])
+ case "$gt_cv_int_divbyzero_sigfpe" in
+- *yes) value=1;;
+- *) value=0;;
++ *yes) value=1 ;;
++ *) value=0 ;;
+ esac
+ AC_DEFINE_UNQUOTED([INTDIV0_RAISES_SIGFPE], [$value],
+ [Define if integer division by zero raises signal SIGFPE.])