summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-05-18 17:58:12 +0200
committerDavid Seifert <soap@gentoo.org>2023-05-18 17:58:12 +0200
commit8d8ee54006fee91e9b14779aa54d1fe91510cb8b (patch)
treed084f5c22ce48ef2287165ed565a5050237252df /app-crypt
parentdev-util/bpftool: drop 6.2.11 (diff)
downloadgentoo-8d8ee54006fee91e9b14779aa54d1fe91510cb8b.tar.gz
gentoo-8d8ee54006fee91e9b14779aa54d1fe91510cb8b.tar.bz2
gentoo-8d8ee54006fee91e9b14779aa54d1fe91510cb8b.zip
app-crypt/simple-tpm-pk11: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild (renamed from app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild)32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild
index 6b5facd3a1c1..fe55cfddc7f0 100644
--- a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild
+++ b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild
@@ -1,16 +1,11 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
-DESCRIPTION="Simple PKCS11 provider for TPM chips"
-HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/ThomasHabets/${PN}.git"
inherit git-r3
else
@@ -18,28 +13,31 @@ else
KEYWORDS="~amd64"
fi
+DESCRIPTION="Simple PKCS11 provider for TPM chips"
+HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
+
+LICENSE="Apache-2.0"
+SLOT="0"
RESTRICT="test" # needs to communicate with the TPM and gtest is all broken
-DEPEND="app-crypt/tpm-tools[pkcs11]
- dev-libs/opencryptoki[tpm]
+DEPEND="
+ app-crypt/tpm-tools[pkcs11]
app-crypt/trousers
- dev-libs/openssl:0=
- "
+ dev-libs/opencryptoki[tpm]
+ dev-libs/openssl:=
+"
RDEPEND="${DEPEND}
|| (
>=net-misc/openssh-9.3_p1-r1
>=net-misc/openssh-contrib-9.3_p1[-X509]
- )"
+ )
+"
src_prepare() {
- eapply_user
+ default
eautoreconf
}
-src_configure() {
- econf --disable-static
-}
-
src_install() {
default
find "${ED}" -name '*.la' -delete || die