summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-02-15 10:50:01 +0200
committerStefan Strogin <steils@gentoo.org>2020-02-15 10:50:01 +0200
commit96076573ffc3c9e64a31dd6258129bd5044bb9ee (patch)
treeff139d61f58536d24fba26a16f7f51ec4dfb267e /app-crypt
parentdev-ruby/twitter: add 7.0.0 (diff)
downloadgentoo-96076573ffc3c9e64a31dd6258129bd5044bb9ee.tar.gz
gentoo-96076573ffc3c9e64a31dd6258129bd5044bb9ee.tar.bz2
gentoo-96076573ffc3c9e64a31dd6258129bd5044bb9ee.zip
app-crypt/mit-krb5: add patch for LibreSSL for 1.18
Closes: https://bugs.gentoo.org/709640 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/mit-krb5/files/mit-krb5-1.18-libressl.patch42
-rw-r--r--app-crypt/mit-krb5/mit-krb5-1.18.ebuild1
2 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/mit-krb5/files/mit-krb5-1.18-libressl.patch b/app-crypt/mit-krb5/files/mit-krb5-1.18-libressl.patch
new file mode 100644
index 000000000000..1522d42a730f
--- /dev/null
+++ b/app-crypt/mit-krb5/files/mit-krb5-1.18-libressl.patch
@@ -0,0 +1,42 @@
+From e3e3bc2a20795becda6e130d511fe59f04635624 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <steils@gentoo.org>
+Date: Sat, 15 Feb 2020 10:27:20 +0200
+Subject: [PATCH] Fix compilation for LibreSSL 3.0.2
+
+RSA_PKCS1_OpenSSL() is provided in LibreSSL the master branch,
+expected to be in the next release.
+See: https://github.com/libressl-portable/openbsd/commit/3a8c41f3a84868337fde01ec1122198ec60bdc8e
+
+Bug: https://bugs.gentoo.org/709640
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ tests/softpkcs11/main.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/tests/softpkcs11/main.c b/tests/softpkcs11/main.c
+index 1cccdfb43..a5099fbe4 100644
+--- a/tests/softpkcs11/main.c
++++ b/tests/softpkcs11/main.c
+@@ -47,7 +47,6 @@
+
+ #if OPENSSL_VERSION_NUMBER < 0x10100000L
+ #define EVP_PKEY_get0_RSA(key) ((key)->pkey.rsa)
+-#define RSA_PKCS1_OpenSSL RSA_PKCS1_SSLeay
+ #define RSA_get0_key compat_rsa_get0_key
+ static void
+ compat_rsa_get0_key(const RSA *rsa, const BIGNUM **n, const BIGNUM **e,
+@@ -62,6 +61,11 @@ compat_rsa_get0_key(const RSA *rsa, const BIGNUM **n, const BIGNUM **e,
+ }
+ #endif
+
++#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || \
++ defined(LIBRESSL_VERSION_NUMBER) && (LIBRESSL_VERSION_NUMBER <= 0x3000200fL)
++#define RSA_PKCS1_OpenSSL RSA_PKCS1_SSLeay
++#endif
++
+ #define OPENSSL_ASN1_MALLOC_ENCODE(T, B, BL, S, R) \
+ { \
+ unsigned char *p; \
+--
+2.25.0
+
diff --git a/app-crypt/mit-krb5/mit-krb5-1.18.ebuild b/app-crypt/mit-krb5/mit-krb5-1.18.ebuild
index 393c85034b87..2c9031b2e109 100644
--- a/app-crypt/mit-krb5/mit-krb5-1.18.ebuild
+++ b/app-crypt/mit-krb5/mit-krb5-1.18.ebuild
@@ -63,6 +63,7 @@ PATCHES=(
"${FILESDIR}/${PN}-config_LDFLAGS-r1.patch"
"${FILESDIR}/${PN}-1.16.3-libressl-r1.patch"
"${FILESDIR}/${PN}_dont_create_run.patch"
+ "${FILESDIR}/${P}-libressl.patch"
)
MULTILIB_CHOST_TOOLS=(