summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <david.michael@coreos.com>2017-06-14 17:41:13 -0700
committerVirgil Dupras <vdupras@gentoo.org>2018-09-28 21:01:48 -0400
commitab3ba62b708cd6829fbe939eef827b56ad9411bc (patch)
tree62ce28678d57c5302b3646ef229199cf28635990 /app-crypt
parentprofiles: last-riting dev-python/tinydb (diff)
downloadgentoo-ab3ba62b708cd6829fbe939eef827b56ad9411bc.tar.gz
gentoo-ab3ba62b708cd6829fbe939eef827b56ad9411bc.tar.bz2
gentoo-ab3ba62b708cd6829fbe939eef827b56ad9411bc.zip
app-crypt/pesign: Supply cross-compiling programs
(with minor style changes from vdupras) Closes: https://bugs.gentoo.org/621804 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pesign/pesign-0.112.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-crypt/pesign/pesign-0.112.ebuild b/app-crypt/pesign/pesign-0.112.ebuild
index 314dcb7d8cd1..3937fb8fdcd6 100644
--- a/app-crypt/pesign/pesign-0.112.ebuild
+++ b/app-crypt/pesign/pesign-0.112.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -35,7 +35,13 @@ PATCHES=(
)
src_compile() {
- emake CC="$(tc-getCC)"
+ emake AR="$(tc-is-gcc && echo "$(tc-getCC)-ar" || tc-getAR)" \
+ AS="$(tc-getAS)" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ OBJCOPY="$(tc-getOBJCOPY)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ RANLIB="$(tc-getRANLIB)"
}
src_install() {
@@ -44,5 +50,5 @@ src_install() {
# remove some files that don't make sense for Gentoo installs
rm -rf "${ED%/}/etc/" "${ED%/}/var/" \
- "${ED%/}/usr/share/doc/${PF}/COPYING" || die
+ "${ED%/}/usr/share/doc/${PF}/COPYING" || die
}