summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-11 22:01:33 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-11 22:01:36 +0200
commitb028c94d86ff7d243a067e747f59cf2f2971e95a (patch)
tree9a46b0d2f79c021f04e3f8eee328f63e0a4003eb /app-crypt
parentapp-crypt/acme: enable py3.10, fix tests and more (diff)
downloadgentoo-b028c94d86ff7d243a067e747f59cf2f2971e95a.tar.gz
gentoo-b028c94d86ff7d243a067e747f59cf2f2971e95a.tar.bz2
gentoo-b028c94d86ff7d243a067e747f59cf2f2971e95a.zip
app-crypt/acme: sync live ebuild with 1.18.0-r1
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/acme-9999.ebuild47
1 files changed, 9 insertions, 38 deletions
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 6e86a07321fd..7c666ebed1ff 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=(python{3_7,3_8,3_9})
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
inherit git-r3
@@ -15,54 +18,22 @@ else
S=${WORKDIR}/certbot-${PV}/acme
fi
-inherit distutils-r1
-
DESCRIPTION="An implementation of the ACME protocol"
HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
>=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]
- >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
>=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
>=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
"
-DEPEND="
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
- distutils-r1_src_compile
- if use doc ; then
- cd docs || die
- sphinx-build -b html -d _build/doctrees . _build/html
- fi
-}
-
-python_test() {
- nosetests -w ${PN} || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest