summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-09-09 23:33:49 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-09-09 23:34:09 -0500
commitc2b99a27ee35dda885e7b31186bbe900ad28057e (patch)
tree1cffd8df14d3a0880944ea8ce2e42ad7f58f4cc3 /app-crypt
parentapp-crypt/certbot-apache: 1.8.0 bump (diff)
downloadgentoo-c2b99a27ee35dda885e7b31186bbe900ad28057e.tar.gz
gentoo-c2b99a27ee35dda885e7b31186bbe900ad28057e.tar.bz2
gentoo-c2b99a27ee35dda885e7b31186bbe900ad28057e.zip
app-crypt/certbot-nginx: 1.8.0 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.8.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 052b267e8898..840e9863bf61 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1 +1,2 @@
DIST certbot-1.7.0.tar.gz 1416764 BLAKE2B de678a222e8c8e3e7834470f87763763671bfae37a5c8320a4c1a2552ec979b5391094713e7e13526f73fdf8cd32f70f8c4350f422505892c4fdd0ae77742c80 SHA512 f81242e68b7e261bbb6294ffe92e47bc1687128344816d71a495a94a2646e209e46c147bc76eedce0c477cc140dc6ae0fba76d2d5d01b828fce78875f5a2886a
+DIST certbot-1.8.0.tar.gz 1425620 BLAKE2B 9cc0443fd067bf594f02a79c99defa250e656dbee00cd2717a4a747abfe80511ffcb800b6ac63e484a918192dad9465dc45335f358267fa998af16e966b8e2a6 SHA512 c6559fe1e5db6269942bda3738c00b1b550ec448288eaf911ba9c3967c7e949b34bdd8b77742398f0a512ce07929fa2f227c1202e40900151762f1db6ff9de56
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.8.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.8.0.ebuild
new file mode 100644
index 000000000000..1d92bc0c30fa
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.8.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=app-crypt/acme-1.4.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-1.6.0[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"