summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-10-15 15:51:31 -0700
committerDavid Seifert <soap@gentoo.org>2017-10-15 17:05:09 -0700
commitc6f464b46a7d2cfcbc41554cb6df1337afad87d2 (patch)
tree07122f0272faf429e3e35c324327494531b360a4 /app-crypt
parentapp-cdr/gcdemu: [QA] Add cmake-utils_src_prepare (diff)
downloadgentoo-c6f464b46a7d2cfcbc41554cb6df1337afad87d2.tar.gz
gentoo-c6f464b46a7d2cfcbc41554cb6df1337afad87d2.tar.bz2
gentoo-c6f464b46a7d2cfcbc41554cb6df1337afad87d2.zip
app-crypt/tpm-emulator: [QA] Add cmake-utils_src_prepare
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild b/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
index 8b41e36c664b..2e719e5b28ba 100644
--- a/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
+++ b/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
@@ -34,14 +34,15 @@ pkg_setup() {
}
src_prepare() {
- default
+ cmake-utils_src_prepare
+
# do not build and install the kernel module
sed -i 's/COMMAND ${tpmd_dev_BUILD_CMD}//' tpmd_dev/CMakeLists.txt || die
sed -i 's/install(CODE.*//' tpmd_dev/CMakeLists.txt || die
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DUSE_OPENSSL=$(usex ssl)
)
cmake-utils_src_configure