summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-09-10 22:54:31 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-09-10 22:55:06 -0500
commitcba9d45170dd102570cf46bf8459e49f86a57446 (patch)
treea786e9f346dcbc28e7235126e8bb02fa6c47adf9 /app-crypt
parentapp-crypt/certbot-apache: add 1.30.0 (diff)
downloadgentoo-cba9d45170dd102570cf46bf8459e49f86a57446.tar.gz
gentoo-cba9d45170dd102570cf46bf8459e49f86a57446.tar.bz2
gentoo-cba9d45170dd102570cf46bf8459e49f86a57446.zip
app-crypt/certbot-nginx: add 1.30.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.30.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 5974cb4f2eca..8ae96f64bfb0 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1 +1,2 @@
DIST certbot-1.29.0.tar.gz 1367853 BLAKE2B c0d8d2c05a061b2d50564a97bf17ae883bd443321bf99cea13fbae196c7ec876231d803d5389e524997dd8632035d5ad60b1a99b025a22a65d0865d564cfafc5 SHA512 755781e12e0e4cdb41aa16d90ab6a334ef41a98630e08127a867c8e8813ee45ebd3f6f54168fe747900f6ab59539e414ffed7891c05746b3a7af2e2a96a8d522
+DIST certbot-1.30.0.tar.gz 1370072 BLAKE2B c9286bc6dfee59c5a7b458430b08ee273615b42e40d2355b41c5d58a0b8757d83551e947058660e4abda88d7f11c16184a248c313b4d01e145df0e39b717bf86 SHA512 15727a7a38a9cbe4890a347c0cc2a795be19502ece28034400d41cf96a6d4bef197890bd85cd02ecc6a792e3502ae8aa663aad45e980047567f0d3b161cbe3df
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.30.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.30.0.ebuild
new file mode 100644
index 000000000000..7eeac389284d
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.30.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.1[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest