summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMason Rocha <turret@turret.cyou>2023-11-21 20:03:36 -0600
committerSam James <sam@gentoo.org>2024-01-20 11:48:33 +0000
commitd0f3c17b8eba3e2af33853922104c18ead580bea (patch)
tree98524989b8333b1cb33bc4677e4bc5e842b4828b /app-crypt
parentapp-crypt/ccid: add myself as new maintainer (diff)
downloadgentoo-d0f3c17b8eba3e2af33853922104c18ead580bea.tar.gz
gentoo-d0f3c17b8eba3e2af33853922104c18ead580bea.tar.bz2
gentoo-d0f3c17b8eba3e2af33853922104c18ead580bea.zip
app-crypt/ccid: version bump 1.5.4
upstream introduces in version 1.5.3 a hard-dependency on sys-devel/flex, which has been historically a soft-dependency, ignored by previous maintainers (see https://bugs.gentoo.org/221361) patch included removes dependency, permitting proper install of package without flex, as possible in the past due to upstream tarballs pre-generating required files Bug: https://bugs.gentoo.org/221361 Signed-off-by: Mason Rocha <turret@turret.cyou> Closes: https://github.com/gentoo/gentoo/pull/33933 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/ccid/Manifest1
-rw-r--r--app-crypt/ccid/ccid-1.5.4.ebuild55
-rw-r--r--app-crypt/ccid/files/ccid-1.5.4-remove-flex-configure-dependency.patch16
3 files changed, 72 insertions, 0 deletions
diff --git a/app-crypt/ccid/Manifest b/app-crypt/ccid/Manifest
index 2d167910e1fb..e801a4a101a1 100644
--- a/app-crypt/ccid/Manifest
+++ b/app-crypt/ccid/Manifest
@@ -1 +1,2 @@
DIST ccid-1.5.1.tar.bz2 702586 BLAKE2B 7b9e3c6daf03c186f34ac9b13bd960293a6481f9237ee52937ece1040bd3a79b7dab318e1244205a7feae992261ab5e82292d80ae023a4f621e0e7af7cdb9df5 SHA512 492bde96f5752e2a5316693c44e35e2d041785a00d15e094905c0aafad392f5329009d12801899367276328a582936ee53a1c5239c1813c4536001cb8a608f2e
+DIST ccid-1.5.4.tar.bz2 706834 BLAKE2B 8b7f08145808ac94d085eef62c204f8146892cb11f2ce811e46e674272cab016d602afb945c6e808ce3957a80e847c0de2815fedaf15fc8c935cafaccf102762 SHA512 4b30f4768aebf49486a1b1e959615fa077bd393bfdd9e52c15bdc8d6ed63ce27fa7cf82a067d1f80d8b3534c66194036925d3fea5af64b6a775779d38267c757
diff --git a/app-crypt/ccid/ccid-1.5.4.ebuild b/app-crypt/ccid/ccid-1.5.4.ebuild
new file mode 100644
index 000000000000..f7a11ceca111
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.5.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools udev
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="https://ccid.apdu.fr https://github.com/LudovicRousseau/CCID"
+SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="twinserial +usb"
+
+RDEPEND="
+ >=sys-apps/pcsc-lite-1.8.3
+ twinserial? ( dev-lang/perl )
+ usb? ( virtual/libusb:1 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-flex-configure-dependency.patch
+)
+
+src_prepare() {
+ default
+
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ LEX=: \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_install() {
+ default
+ udev_newrules src/92_pcscd_ccid.rules 92-pcsc-ccid.rules
+}
+
+pkg_postinst() {
+ udev_reload
+ einfo "Check https://github.com/LudovicRousseau/CCID/blob/master/INSTALL"
+ einfo "for more info about how to configure and use ccid"
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-crypt/ccid/files/ccid-1.5.4-remove-flex-configure-dependency.patch b/app-crypt/ccid/files/ccid-1.5.4-remove-flex-configure-dependency.patch
new file mode 100644
index 000000000000..564532c9ab42
--- /dev/null
+++ b/app-crypt/ccid/files/ccid-1.5.4-remove-flex-configure-dependency.patch
@@ -0,0 +1,16 @@
+Bug: https://bugs.gentoo.org/221361
+Reverts upstream commit eec7cdf0
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -32,11 +32,6 @@ AC_PROG_CPP
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+ AC_PROG_LN_S
+-AC_PROG_LEX([noyywrap])
+-if test $LEX = ":"
+-then
+- AC_MSG_ERROR([no lex or flex found])
+-fi
+ AM_PROG_AR
+ PKG_PROG_PKG_CONFIG