summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-06-07 14:26:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-06-07 14:53:28 -0500
commitdad0ab3dd07ac8b9d2d9b5cdedb54c22222f9ee0 (patch)
treeb7f3545d82bb1a9aef4dc881c58edccdbea71cb1 /app-crypt
parentnet-dns/dnscap: EAPI=7, improve ebuild, fix HTTPS (diff)
downloadgentoo-dad0ab3dd07ac8b9d2d9b5cdedb54c22222f9ee0.tar.gz
gentoo-dad0ab3dd07ac8b9d2d9b5cdedb54c22222f9ee0.tar.bz2
gentoo-dad0ab3dd07ac8b9d2d9b5cdedb54c22222f9ee0.zip
app-crypt/acme: 0.25.0 bup
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme/Manifest1
-rw-r--r--app-crypt/acme/acme-0.25.0.ebuild48
-rw-r--r--app-crypt/acme/acme-9999.ebuild1
3 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index af62754b0704..cf0c716a4f32 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,2 +1,3 @@
DIST certbot-0.23.0.tar.gz 1144448 BLAKE2B 820c4e3a0245a4ccda90884e38093d4f95ebf8c06ccb93c80a277a69074a6ab3bac3451f4e8f9af6c1c36edd9d871e10de9240d847e6eeac5fb8e0fbcdb3cdcb SHA512 397562fa7f5ef5daea8ccf70dc21898f8b792dc6a07aa24035fa378da8af3dd5d0734c3fbf6080c28d17f050db46ec0ea637be81d4ce648fa5ab2add2cfd41ed
DIST certbot-0.24.0.tar.gz 1149694 BLAKE2B 7c57d59ced97de77e0f98eb11a2bba418ee81ba0eb4506ebc010cb0060c92820617ba2a3464dd398bfec6dc86f4c2dc8e22461d76ae51ccfbb97afab3bbb3681 SHA512 b067da7eea54deb72ff4b516382cbe480ffebcb378489a2b0c52955f7399401d936d8d6587d88473d6f4fa9e864de94514941bde9727a5babbf2d6211ea61b20
+DIST certbot-0.25.0.tar.gz 1163858 BLAKE2B 9439b253a505f3cfb25f4ca33e6745b53ac51514dc34b31dd234c8db7dd07b9cb47b0a7edcc565dd7dee4678d0edd99590d2f235fedb77193e8ad1f0459c6b7a SHA512 af0f2498d79e9d54f0609b21b8ec40efe9fbcfa5162eb18bbb8b10cc230b31db6af81c4e85af243d92c527efc55634402b30960d014085f6e6af6e679ca75592
diff --git a/app-crypt/acme/acme-0.25.0.ebuild b/app-crypt/acme/acme-0.25.0.ebuild
new file mode 100644
index 000000000000..7c82dc6d67c0
--- /dev/null
+++ b/app-crypt/acme/acme-0.25.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.0.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ nosetests -w ${PN} || die
+}
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index 3a1dd1461249..d408adeca31b 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -31,6 +31,7 @@ RDEPEND="
dev-python/pyrfc3339[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
"
DEPEND="