summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-12-25 13:54:47 -0600
committerMatthias Maier <tamiko@gentoo.org>2022-12-25 13:59:35 -0600
commite588304d0152584186f69c0cab0e1e99462c7ab7 (patch)
tree302609af745eafee436e1dbe904aab0dca011146 /app-crypt
parentdev-cpp/abseil-cpp: Stabilize 20220623.1 arm64, #888455 (diff)
downloadgentoo-e588304d0152584186f69c0cab0e1e99462c7ab7.tar.gz
gentoo-e588304d0152584186f69c0cab0e1e99462c7ab7.tar.bz2
gentoo-e588304d0152584186f69c0cab0e1e99462c7ab7.zip
app-crypt/jitterentropy-rngd: add 1.2.8
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/jitterentropy-rngd/Manifest1
-rw-r--r--app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy-rngd/Manifest b/app-crypt/jitterentropy-rngd/Manifest
index 432b1f574f94..74c99ee7cd19 100644
--- a/app-crypt/jitterentropy-rngd/Manifest
+++ b/app-crypt/jitterentropy-rngd/Manifest
@@ -1 +1,2 @@
DIST jitterentropy-rngd-1.2.7.tar.gz 46546 BLAKE2B 82f0610ab5e2dd4ac42b5c2a72a59cc9c78dd65f82327302d4699b129280d45bf61a7197d44d3d141b6ccd3b512b984b0f95f1594c97a8c54f10c0d58906089c SHA512 4d89110cb7456b360f4c268121b61c2141b9d592877728eb94de0c8679928689b3b039a99579af4ee1299a1eb538c9a2d4527d9a4e98f85022c590a0d01f4811
+DIST jitterentropy-rngd-1.2.8.tar.gz 46950 BLAKE2B 67e6a590bf5d535a6f8cf465b8c6f59ccc101e699979573e117432545800e42393e2232f5a3404f03f7806eb79c4a3148a14eb35f660233926ac874ad5207779 SHA512 9cc2c66388f592e2e4df89e0e9950dc83af168658dd456c9b1af9883cce7ce5f6ece37089d7dbfb0bb61433a52bf596d129819b3328551f2ec29a5d74f94ea47
diff --git a/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild
new file mode 100644
index 000000000000..1d082547ec2f
--- /dev/null
+++ b/app-crypt/jitterentropy-rngd/jitterentropy-rngd-1.2.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic linux-info systemd
+
+DESCRIPTION="Jitter RNG daemon"
+HOMEPAGE="https://www.chronox.de/jent.html"
+SRC_URI="https://github.com/smuellerDD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-do-not-strip-and-compress.patch
+)
+
+src_configure() {
+ filter-flags '*'
+ append-cflags '-O0'
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" \
+ UNITDIR="$(systemd_get_systemunitdir)" install
+ newinitd "${FILESDIR}"/jitterentropy-rngd-initd jitterentropy-rngd
+}