summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-19 11:45:39 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-03-19 11:53:15 +0100
commitebe40f65ccf0618947fe31b55c7a1ac5e4748716 (patch)
tree866f948dae6966e6cb3085bec2b3901506aaffab /app-crypt
parentgui-apps/wayvnc: Bump to 0.6.2, drop old 0.4.0-r1 (diff)
downloadgentoo-ebe40f65ccf0618947fe31b55c7a1ac5e4748716.tar.gz
gentoo-ebe40f65ccf0618947fe31b55c7a1ac5e4748716.tar.bz2
gentoo-ebe40f65ccf0618947fe31b55c7a1ac5e4748716.zip
app-crypt/mhash: generate a pck-config file
Closes: https://bugs.gentoo.org/895562 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/mhash/files/mhash.pc4
-rw-r--r--app-crypt/mhash/mhash-0.9.9.9-r3.ebuild (renamed from app-crypt/mhash/mhash-0.9.9.9-r2.ebuild)10
2 files changed, 12 insertions, 2 deletions
diff --git a/app-crypt/mhash/files/mhash.pc b/app-crypt/mhash/files/mhash.pc
new file mode 100644
index 000000000000..6186f85c7839
--- /dev/null
+++ b/app-crypt/mhash/files/mhash.pc
@@ -0,0 +1,4 @@
+Libs:-lmhash
+Name: mhash
+Version: @VERSION@
+Description: provides a uniform interface to several hash algorithms
diff --git a/app-crypt/mhash/mhash-0.9.9.9-r2.ebuild b/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
index e31cbe8e8e25..d8cba554e436 100644
--- a/app-crypt/mhash/mhash-0.9.9.9-r2.ebuild
+++ b/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -39,6 +39,10 @@ src_prepare() {
-e 's/--netscape//' \
"${S}"/doc/Makefile.in || die
+ sed \
+ -e "s:@VERSION@:${PV}:" \
+ "${FILESDIR}"/${PN}.pc > ${PN}.pc || die
+
# Refresh bundled libtool (ltmain.sh)
# (elibtoolize is not sufficient)
# bug #668666
@@ -57,5 +61,7 @@ src_compile() {
src_install() {
default
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins ${PN}.pc
find "${ED}" -name '*.la' -delete || die
}