summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2022-01-19 09:47:05 -0500
committerAdam Feldman <NP-Hardass@gentoo.org>2022-02-17 13:40:53 -0500
commitedafb60c9552b1504bd97c5698e8110960f6c32c (patch)
tree81008948cd6e289b1cb5b60ab7441c6a13cec11a /app-crypt
parentapp-crypt/gpgme: [QA] add base-system@ as a backup maintainer (diff)
downloadgentoo-edafb60c9552b1504bd97c5698e8110960f6c32c.tar.gz
gentoo-edafb60c9552b1504bd97c5698e8110960f6c32c.tar.bz2
gentoo-edafb60c9552b1504bd97c5698e8110960f6c32c.zip
app-crypt/acme-tiny: Version bump 5.0.1
Add Python 3.10 support Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Anthony Ryan <anthonyryan1@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23870 Closes: https://bugs.gentoo.org/830415 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acme-tiny/Manifest1
-rw-r--r--app-crypt/acme-tiny/acme-tiny-5.0.1.ebuild47
-rw-r--r--app-crypt/acme-tiny/acme-tiny-9999.ebuild4
3 files changed, 50 insertions, 2 deletions
diff --git a/app-crypt/acme-tiny/Manifest b/app-crypt/acme-tiny/Manifest
index 10ca796d5030..3c2337792f19 100644
--- a/app-crypt/acme-tiny/Manifest
+++ b/app-crypt/acme-tiny/Manifest
@@ -1 +1,2 @@
DIST acme-tiny-4.1.0.tar.gz 12776 BLAKE2B 7efd9d1399ec3bbd98180511c9f36fbf6f9a96a0d4e0e72b9d4c85d16246118eaaad25bc26ba42f746fd4b60b498ceca5307e279d788157237ac6ad153848501 SHA512 31d69a5031c019acbc23b3f06041eae8e261766396d4a7420fd70a71cfa16de953bea4c0c2ad0c6a6e793ed61ab5331f40145352ffce69f4f062f35dd0db7519
+DIST acme-tiny-5.0.1.tar.gz 21036 BLAKE2B a09c16ca19570b48d34c919e2a361e3be5d66ed8fc0ccff7af74e4018d294f2940a552906dee45bac27a16e7b039a3567dc35e201b058015c5123baa2cbb01c1 SHA512 6e0619917b31a5795c2c7d8aa811b46231b81fc6b57227f611f7f4b9f73eb3de669676482563c33d935a4a0812498677bcbe974663a561af61abb441a880947e
diff --git a/app-crypt/acme-tiny/acme-tiny-5.0.1.ebuild b/app-crypt/acme-tiny/acme-tiny-5.0.1.ebuild
new file mode 100644
index 000000000000..b1ca9c31e4af
--- /dev/null
+++ b/app-crypt/acme-tiny/acme-tiny-5.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8,3_9,3_10} )
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/diafygi/${PN}.git"
+else
+ SRC_URI="https://github.com/diafygi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A tiny, auditable script for Let's Encrypt's ACME Protocol"
+HOMEPAGE="https://github.com/diafygi/acme-tiny"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/openssl:0"
+
+pkg_setup() {
+ if [[ ${PV} != 9999 ]]; then
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ fi
+}
+
+src_prepare() {
+ sed -i 's|#!/usr/bin/sh|#!/bin/sh|g' README.md || die
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "$v" "-lt" "4.0.3" || ver_test "$v" "-ge" "9999"; then
+ einfo "The --account-email flag has been changed to --contact and"
+ einfo "has different syntax."
+ einfo "Please update your scripts accordingly"
+ fi
+ done
+}
diff --git a/app-crypt/acme-tiny/acme-tiny-9999.ebuild b/app-crypt/acme-tiny/acme-tiny-9999.ebuild
index 5c6c1c7e6e6b..b1ca9c31e4af 100644
--- a/app-crypt/acme-tiny/acme-tiny-9999.ebuild
+++ b/app-crypt/acme-tiny/acme-tiny-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+PYTHON_COMPAT=( python{3_7,3_8,3_9,3_10} )
inherit distutils-r1
if [[ ${PV} == 9999 ]]; then