summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2021-04-19 22:24:18 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-04 16:38:50 +0300
commit1bbff0327bf706c0dc1c1e2c8e3804880f6ff0ab (patch)
treedf35b9056f380a256ed8ea4bab6e2ab9b1671b80 /app-dicts/myspell-ca/myspell-ca-3.0.6.ebuild
parentx11-misc/xplanet: Really do the revbump this time (diff)
downloadgentoo-1bbff0327bf706c0dc1c1e2c8e3804880f6ff0ab.tar.gz
gentoo-1bbff0327bf706c0dc1c1e2c8e3804880f6ff0ab.tar.bz2
gentoo-1bbff0327bf706c0dc1c1e2c8e3804880f6ff0ab.zip
app-dicts/myspell-ca: take maintainership, bump to 3.0.6
Closes: https://bugs.gentoo.org/784224 Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20463 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts/myspell-ca/myspell-ca-3.0.6.ebuild')
-rw-r--r--app-dicts/myspell-ca/myspell-ca-3.0.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-dicts/myspell-ca/myspell-ca-3.0.6.ebuild b/app-dicts/myspell-ca/myspell-ca-3.0.6.ebuild
new file mode 100644
index 000000000000..ba020ff6f8a6
--- /dev/null
+++ b/app-dicts/myspell-ca/myspell-ca-3.0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=(
+ "ca_ES.aff"
+ "ca_ES.dic"
+ "ca_ES-valencia.aff"
+ "ca_ES-valencia.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_ca_ES.dic"
+)
+
+MYSPELL_THES=(
+ "th_ca_ES_v3.idx"
+ "th_ca_ES_v3.dat"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Catalan dictionaries for myspell/hunspell"
+HOMEPAGE="https://www.softcatala.org/programes/corrector-ortografic-de-catala-general-per-al-libreoffice-i-lapache-openoffice/ https://github.com/Softcatala/catalan-dict-tools/"
+SRC_URI="https://github.com/Softcatala/catalan-dict-tools/releases/download/v${PV}/ca.${PV}.oxt"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+src_prepare() {
+ default
+
+ # rename to conform the common naming scheme
+ mv ca.aff ca_ES.aff || die
+ mv ca.dic ca_ES.dic || die
+ mv ca-ES-valencia.aff ca_ES-valencia.aff || die
+ mv ca-ES-valencia.dic ca_ES-valencia.dic || die
+ mv hyph_ca.dic hyph_ca_ES.dic || die
+
+ # remove licenses
+ rm LICENSES-en.txt LLICENCIES-ca.txt || die
+}