summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-06-05 11:49:48 +0200
committerPacho Ramos <pacho@gentoo.org>2017-06-05 11:49:48 +0200
commit2c6765dcb5d7f66054d0d2a04219df35faf4c607 (patch)
treeb0c9475646614b9cbd1c3eb32d10d9c5f6d7405e /app-dicts/opendict/opendict-0.6.7.ebuild
parentpackage.mask: unmask audacity-2.1.3 (#584024) (diff)
downloadgentoo-2c6765dcb5d7f66054d0d2a04219df35faf4c607.tar.gz
gentoo-2c6765dcb5d7f66054d0d2a04219df35faf4c607.tar.bz2
gentoo-2c6765dcb5d7f66054d0d2a04219df35faf4c607.zip
app-dicts/opendict: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-dicts/opendict/opendict-0.6.7.ebuild')
-rw-r--r--app-dicts/opendict/opendict-0.6.7.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/app-dicts/opendict/opendict-0.6.7.ebuild b/app-dicts/opendict/opendict-0.6.7.ebuild
new file mode 100644
index 000000000000..026546d15248
--- /dev/null
+++ b/app-dicts/opendict/opendict-0.6.7.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="OpenDict is a free cross-platform dictionary program"
+HOMEPAGE="http://opendict.sourceforge.net/"
+SRC_URI="mirror://sourceforge/opendict/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="If you want system-wide plugins, unzip them into
+${ROOT}usr/share/${PN}/dictionaries/plugins
+
+Some are available from http://opendict.sourceforge.net/?cid=3"
+
+src_prepare() {
+ sed -e "s:), '..')):), '../../../../..', 'share', 'opendict')):g" \
+ -i "${S}/lib/info.py"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # override gnome2_src_configure
+ default
+}
+
+src_compile() {
+ # evil makefile
+ :
+}
+
+src_install() {
+ # makefile is broken, do it manually
+
+ dodir /usr/share/${PN}/dictionaries/plugins # global dictionary plugins folder
+
+ # Needed by GUI
+ insinto /usr/share/${PN}
+ doins "${S}"/copying.html
+
+ insinto /usr/share/${PN}/pixmaps
+ doins "${S}"/pixmaps/*
+
+ DHOME="$(python_get_sitedir)/opendict"
+ insinto "${DHOME}/lib"
+ doins -r "${S}"/lib/*
+ exeinto "${DHOME}"
+ python_fix_shebang opendict.py
+ doexe opendict.py
+
+ dosym "${DHOME}/opendict.py" /usr/bin/opendict
+
+ domenu misc/${PN}.desktop
+
+ insinto /usr/share/icons/hicolor/24x24/apps/
+ newins "${S}/pixmaps/icon-24x24.png" opendict.png
+ insinto /usr/share/icons/hicolor/32x32/apps/
+ newins "${S}/pixmaps/icon-32x32.png" opendict.png
+ insinto /usr/share/icons/hicolor/48x48/apps/
+ newins "${S}/pixmaps/icon-48x48.png" opendict.png
+ insinto /usr/share/icons/hicolor/scalable/apps/
+ newins "${S}/pixmaps/SVG/icon-rune.svg" opendict.svg
+
+ doman opendict.1
+ dodoc README.txt TODO.txt doc/Plugin-HOWTO.html
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}