summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-09-15 21:52:27 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-15 21:52:27 +0200
commit137c26e86e2791c8cf73f0cb7b52cd7be965b659 (patch)
treefedcdb4cc9eb7039452aa1580d4eac5fec0ac937 /app-dicts
parentwww-client/opera: Version 70.0.3728.178 (diff)
downloadgentoo-137c26e86e2791c8cf73f0cb7b52cd7be965b659.tar.gz
gentoo-137c26e86e2791c8cf73f0cb7b52cd7be965b659.tar.bz2
gentoo-137c26e86e2791c8cf73f0cb7b52cd7be965b659.zip
app-dicts/eblook: Port to EAPI 7
Closes: https://bugs.gentoo.org/742059 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/eblook/eblook-1.6.1.ebuild13
-rw-r--r--app-dicts/eblook/files/eblook-1.6.1-LDFLAGS.patch20
2 files changed, 24 insertions, 9 deletions
diff --git a/app-dicts/eblook/eblook-1.6.1.ebuild b/app-dicts/eblook/eblook-1.6.1.ebuild
index c99eec6320c0..79e8ddff2253 100644
--- a/app-dicts/eblook/eblook-1.6.1.ebuild
+++ b/app-dicts/eblook/eblook-1.6.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="Interactive search utility for electronic dictionaries"
HOMEPAGE="http://openlab.ring.gr.jp/edict/eblook/"
@@ -10,19 +10,14 @@ SRC_URI="http://openlab.ring.gr.jp/edict/eblook/dist/${P/_/}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE=""
DEPEND=">=dev-libs/eb-3.3.4"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${P%_*}"
-src_prepare() {
- sed \
- -e 's:LDFAGS:LDFLAGS:g' \
- -i configure || die
-}
+PATCHES=( "${FILESDIR}"/${P}-LDFLAGS.patch )
src_configure() {
- econf --with-eb-conf=/etc/eb.conf
+ econf --with-eb-conf="${EPREFIX}"/etc/eb.conf
}
diff --git a/app-dicts/eblook/files/eblook-1.6.1-LDFLAGS.patch b/app-dicts/eblook/files/eblook-1.6.1-LDFLAGS.patch
new file mode 100644
index 000000000000..79bb33dd0292
--- /dev/null
+++ b/app-dicts/eblook/files/eblook-1.6.1-LDFLAGS.patch
@@ -0,0 +1,20 @@
+--- a/configure
++++ b/configure
+@@ -21918,7 +21918,7 @@
+ save_LIBS=$LIBS
+ CPPFLAGS="$CPPFLAGS $EBCONF_PTHREAD_CPPFLAGS $EBCONF_EBINCS $EBCONF_ZLIBINCS $EBCONF_INTLINCS"
+ CFLAGS="$CFLAGS $EBCONF_PTHREAD_CFLAGS"
+-LDFLAGS="$LDFAGS $EBCONF_PTHREAD_LDFLAGS"
++LDFLAGS="$LDFLAGS $EBCONF_PTHREAD_LDFLAGS"
+ LIBS="$LIBS $EBCONF_EBLIBS $EBCONF_ZLIBLIBS $EBCONF_INTLLIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+@@ -21981,7 +21981,7 @@
+ sysconfdir=$sysconfdir
+ CPPFLAGS="$CPPFLAGS $EBCONF_PTHREAD_CPPFLAGS $EBCONF_EBINCS $EBCONF_ZLIBINCS $EBCONF_INTLINCS"
+ CFLAGS="$CFLAGS $EBCONF_PTHREAD_CFLAGS"
+-LDFLAGS="$LDFAGS $EBCONF_PTHREAD_LDFLAGS"
++LDFLAGS="$LDFLAGS $EBCONF_PTHREAD_LDFLAGS"
+ LIBS="$LIBS $EBCONF_EBLIBS $EBCONF_ZLIBLIBS $EBCONF_INTLLIBS"
+
+