summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2019-11-16 18:36:17 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-11-18 08:14:13 +0200
commita589dc23b0e0179fdf13971881c768c5d24e9da4 (patch)
tree9709b1c4d468c439266c97007c40deb38993320b /app-dicts
parentapp-dicts/myspell-nl: add myself as proxy maintainer (diff)
downloadgentoo-a589dc23b0e0179fdf13971881c768c5d24e9da4.tar.gz
gentoo-a589dc23b0e0179fdf13971881c768c5d24e9da4.tar.bz2
gentoo-a589dc23b0e0179fdf13971881c768c5d24e9da4.zip
app-dicts/myspell-nl: add territory locale formatted entries
Closes: https://bugs.gentoo.org/699660 Signed-off-by: Wim Muskee <wimmuskee@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13675 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-nl/myspell-nl-2.10g-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-dicts/myspell-nl/myspell-nl-2.10g-r2.ebuild b/app-dicts/myspell-nl/myspell-nl-2.10g-r2.ebuild
new file mode 100644
index 000000000000..2663c798ffb0
--- /dev/null
+++ b/app-dicts/myspell-nl/myspell-nl-2.10g-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=(
+ "nl.aff"
+ "nl.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_nl.dic"
+)
+
+MYSPELL_THES=(
+ "th_nl_v2.dat"
+ "th_nl_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Dutch dictionaries for myspell/hunspell"
+HOMEPAGE="https://www.opentaal.org"
+# Thesarus is not versioned at all, I suppose we could bump it with each dict
+# release, or when people say that the download uri checksum changed.
+SRC_URI="
+ https://www.opentaal.org/bestanden/license_result/20-woordenlijst-v-${PV//./}-voor-openofficeorg-3?bid=20&agree=1 -> ${P}.oxt
+ https://data.opentaal.org/opentaalbank/thesaurus/download/thes_nl.oxt -> ${P}_thes.oxt
+"
+
+LICENSE="BSD-2 CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+
+src_prepare() {
+ default
+
+ # rename terroritory specific to just language, bug #607080
+ mv nl_NL.aff nl.aff || die
+ mv nl_NL.dic nl.dic || die
+ mv hyph_nl_NL.dic hyph_nl.dic || die
+
+ # remove dutch translated license so it aint installed
+ rm licentie* || die
+}
+
+src_install() {
+ myspell-r2_src_install
+
+ # make language_territory locale format symlinks to base language files, bug #699660
+ dosym ../hunspell/nl.aff /usr/share/myspell/nl_NL.aff
+ dosym ../hunspell/nl.dic /usr/share/myspell/nl_NL.dic
+ dosym ../hyphen/hyph_nl.dic /usr/share/myspell/hyph_nl_NL.dic
+ dosym ../mythes/th_nl_v2.dat /usr/share/myspell/th_nl_NL_v2.dat
+ dosym ../mythes/th_nl_v2.idx /usr/share/myspell/th_nl_NL_v2.idx
+
+ # Belgium
+ dosym ../hunspell/nl.aff /usr/share/myspell/nl_BE.aff
+ dosym ../hunspell/nl.dic /usr/share/myspell/nl_BE.dic
+ dosym ../hyphen/hyph_nl.dic /usr/share/myspell/hyph_nl_BE.dic
+ dosym ../mythes/th_nl_v2.dat /usr/share/myspell/th_nl_BE_v2.dat
+ dosym ../mythes/th_nl_v2.idx /usr/share/myspell/th_nl_BE_v2.idx
+}