summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2020-05-06 19:11:53 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2020-05-06 19:25:03 +0300
commita57f0605c9455581021ef8b52bd8029c46802132 (patch)
treefb2c033dd8884f2a79ff320692a51b96f39104e2 /app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild
parentapp-admin/clsync: add missed sys-libs/libcap dep (diff)
downloadgentoo-a57f0605c9455581021ef8b52bd8029c46802132.tar.gz
gentoo-a57f0605c9455581021ef8b52bd8029c46802132.tar.bz2
gentoo-a57f0605c9455581021ef8b52bd8029c46802132.zip
app-doc/clsync-docs: require doxygen with dot support
Doxygen must be built with dot support, otherwise dependency graphs will not be built and API documentation will be incomplete. Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild')
-rw-r--r--app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild b/app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..f7465d6bf3bb
--- /dev/null
+++ b/app-doc/clsync-docs/clsync-docs-0.4.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN%-docs}"
+MY_P="${MY_PN}-${PV}"
+
+SRC_URI="https://github.com/clsync/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Clsync and libclsync API documentation"
+HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/clsync/clsync"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="api +examples"
+
+BDEPEND="api? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ : # doxygen doesn't depend on configuration
+}
+
+src_compile() {
+ if use api; then
+ doxygen .doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ dodoc CONTRIB DEVELOPING NOTES PROTOCOL README.md SHORTHANDS TODO
+ if use api; then
+ dodoc -r doc/doxygen/html doc/devel/*
+ fi
+ if use examples; then
+ dodoc -r examples
+ fi
+}