summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-12-15 17:10:14 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-12-15 17:10:14 +0100
commita764ed976501fc5e90b3cea26ce71d027f40f6bf (patch)
tree6fced914405277df257460fd73878a8c506a2810 /app-doc/cppman
parentsci-physics/geant: version bump to 4.11.1.0 (diff)
downloadgentoo-a764ed976501fc5e90b3cea26ce71d027f40f6bf.tar.gz
gentoo-a764ed976501fc5e90b3cea26ce71d027f40f6bf.tar.bz2
gentoo-a764ed976501fc5e90b3cea26ce71d027f40f6bf.zip
app-doc/cppman: add 0.5.4
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-doc/cppman')
-rw-r--r--app-doc/cppman/Manifest1
-rw-r--r--app-doc/cppman/cppman-0.5.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-doc/cppman/Manifest b/app-doc/cppman/Manifest
index c3bac0d61504..e47f31dd3131 100644
--- a/app-doc/cppman/Manifest
+++ b/app-doc/cppman/Manifest
@@ -1 +1,2 @@
DIST cppman-0.5.3.tar.gz 3614734 BLAKE2B 3b764be07c19ad026e20f6b0f1ac6709ef0fba6042225ce53d6aeb627bc80fba4c4775f9c4d9fa7e75f5d5fbc847dffab1eecbca9f55eab0c447b9d6b9f0f401 SHA512 4e89c8e4ec4b8fb7f577ae83ac77198fb2a56f85550b9efa2b534c1e3d25f45be7932e0cfe663d51b5ff2846668022386af0b018056bcc25c5a1b2e5d32eb111
+DIST cppman-0.5.4.tar.gz 3560915 BLAKE2B 37dae8d4f4884582fd4556bfb8778b62e332286b9438a4507dd1a401f40014964a2409a57f1b8d234bb6143555719a6b81ccdf939fcf95a46ddb0fdfd475ac32 SHA512 e401813772c393aaf0e403ee253510ad4aac9cd9733c015e195bb66dad70cb2db0ea3e3c9749d87aed04b49aee04639fa3f822dc8e69a5a8812c3992b3e5c86d
diff --git a/app-doc/cppman/cppman-0.5.4.ebuild b/app-doc/cppman/cppman-0.5.4.ebuild
new file mode 100644
index 000000000000..715dd3be3185
--- /dev/null
+++ b/app-doc/cppman/cppman-0.5.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86 ~x64-macos"
+
+RDEPEND="
+ sys-apps/groff
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+
+ # Don't allow setup.py to install documentation directly
+ sed -i '\:share/doc/cppman:d' setup.py || die "sed failed"
+}