summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-02 00:45:32 +0000
committerSam James <sam@gentoo.org>2021-12-02 00:46:00 +0000
commitea7c804b1bc67dd7093f0e7e376d86af7577a898 (patch)
tree83561222bb3cf9456eab468358030f78bb937429 /app-doc/cppman
parentx11-terms/lilyterm: drop project desktop-misc (diff)
downloadgentoo-ea7c804b1bc67dd7093f0e7e376d86af7577a898.tar.gz
gentoo-ea7c804b1bc67dd7093f0e7e376d86af7577a898.tar.bz2
gentoo-ea7c804b1bc67dd7093f0e7e376d86af7577a898.zip
app-doc/cppman: add 0.5.3
Closes: https://bugs.gentoo.org/827961 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc/cppman')
-rw-r--r--app-doc/cppman/Manifest1
-rw-r--r--app-doc/cppman/cppman-0.5.3.ebuild33
-rw-r--r--app-doc/cppman/test.log1
3 files changed, 35 insertions, 0 deletions
diff --git a/app-doc/cppman/Manifest b/app-doc/cppman/Manifest
index eba741b397ff..29acce160997 100644
--- a/app-doc/cppman/Manifest
+++ b/app-doc/cppman/Manifest
@@ -1 +1,2 @@
DIST cppman-0.5.1.tar.gz 3596049 BLAKE2B 0189da1413720c00c89a0685b83231aaf0c54e19c84ede164e892e7f8855b7b1ceb1baee11866fd99d150e9c031ccea88bcecdda816fb8e53d58b918a000e04a SHA512 3248d9795d3a379f13e43d5e0753f62a0412dcf3760b8dec6a176f08cb71c4983065c7d27eb15ffed4cc77264e66a3f7d9fe5757a8c7a582741751bcfd1b2fd6
+DIST cppman-0.5.3.tar.gz 3614734 BLAKE2B 3b764be07c19ad026e20f6b0f1ac6709ef0fba6042225ce53d6aeb627bc80fba4c4775f9c4d9fa7e75f5d5fbc847dffab1eecbca9f55eab0c447b9d6b9f0f401 SHA512 4e89c8e4ec4b8fb7f577ae83ac77198fb2a56f85550b9efa2b534c1e3d25f45be7932e0cfe663d51b5ff2846668022386af0b018056bcc25c5a1b2e5d32eb111
diff --git a/app-doc/cppman/cppman-0.5.3.ebuild b/app-doc/cppman/cppman-0.5.3.ebuild
new file mode 100644
index 000000000000..0366039efb90
--- /dev/null
+++ b/app-doc/cppman/cppman-0.5.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+RDEPEND="
+ sys-apps/groff
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+
+ # Don't allow setup.py to install documentation directly
+ sed -i '\:share/doc/cppman:d' setup.py || die "sed failed"
+}
diff --git a/app-doc/cppman/test.log b/app-doc/cppman/test.log
new file mode 100644
index 000000000000..db9383193a27
--- /dev/null
+++ b/app-doc/cppman/test.log
@@ -0,0 +1 @@
+basic_ios basic_ios::bad basic_ios::~basic_ios basic_ios::clear basic_ios::copyfmt basic_ios::eof basic_ios::exceptions basic_ios::fail basic_ios::fill basic_ios::good basic_ios::imbue basic_ios::move 'basic_ios::operator!' 'basic_ios::operator bool' basic_ios::rdbuf basic_ios::set_rdbuf basic_iostream::~basic_iostream basic_iostream::basic_iostream 'basic_iostream::operator=' basic_iostream::swap basic_ios::widen ios ios::bad ios_base::event ios_base::event_callback ios_base::fmtflags ios_base::getloc ios_base::imbue ios_base::Init ios_base::ios_base ios_base::iostate ios_base::iword ios_base::openmode ios_base::pword ios_base::register_callback ios_base::seekdir ios_base::setf ios_base::unsetf ios_base::xalloc ios::~basic_ios ios::clear ios::copyfmt ios::eof ios::exceptions ios::fail ios::fill ios::good ios::imbue ios::~ios ios::move 'ios::operator!' 'ios::operator bool' ios::rdbuf ios::set_rdbuf iostream_category ios::widen resetiosflags std::basic_ios std::basic_ios::bad std::basic_ios::~basic_ios std::basic_ios::clear std::basic_ios::copyfmt std::basic_ios::eof std::basic_ios::exceptions std::basic_ios::fail std::basic_ios::fill std::basic_ios::good std::basic_ios::imbue std::basic_ios::move 'std::basic_ios::operator!' 'std::basic_ios::operator bool' std::basic_ios::rdbuf std::basic_ios::set_rdbuf std::basic_iostream::~basic_iostream std::basic_iostream::basic_iostream 'std::basic_iostream::operator=' std::basic_iostream::swap std::basic_ios::widen std::ios std::ios::bad std::ios_base::event std::ios_base::event_callback std::ios_base::fmtflags std::ios_base::getloc std::ios_base::imbue std::ios_base::Init std::ios_base::ios_base std::ios_base::iostate std::ios_base::iword std::ios_base::openmode std::ios_base::pword std::ios_base::register_callback std::ios_base::seekdir std::ios_base::setf std::ios_base::unsetf std::ios_base::xalloc std::ios::~basic_ios std::ios::clear std::ios::copyfmt std::ios::eof std::ios::exceptions std::ios::fail std::ios::fill std::ios::good std::ios::imbue std::ios::~ios std::ios::move 'std::ios::operator!' 'std::ios::operator bool' std::ios::rdbuf std::ios::set_rdbuf std::iostream_category std::ios::widen std::resetiosflags std::wios std::wios::bad std::wios::~basic_ios std::wios::clear std::wios::copyfmt std::wios::eof std::wios::exceptions std::wios::fail std::wios::fill std::wios::good std::wios::imbue std::wios::move 'std::wios::operator!' 'std::wios::operator bool' std::wios::rdbuf std::wios::set_rdbuf std::wios::widen std::wios::~wios wios wios::bad wios::~basic_ios wios::clear wios::copyfmt wios::eof wios::exceptions wios::fail wios::fill wios::good wios::imbue wios::move 'wios::operator!' 'wios::operator bool' wios::rdbuf wios::set_rdbuf wios::widen wios::~wios