summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-02-10 18:58:30 +0100
committerUlrich Müller <ulm@gentoo.org>2020-02-10 19:00:22 +0100
commit504c4020b8aa80a8a391f493e6b38a23a9846c1c (patch)
tree70e01c2cda4c677d161c64600420c1b9d3175ff7 /app-doc/devmanual/devmanual-0_pre20200207.ebuild
parentdev-python/cheroot: Remove old versions (diff)
downloadgentoo-504c4020b8aa80a8a391f493e6b38a23a9846c1c.tar.gz
gentoo-504c4020b8aa80a8a391f493e6b38a23a9846c1c.tar.bz2
gentoo-504c4020b8aa80a8a391f493e6b38a23a9846c1c.zip
app-doc/devmanual: Update live ebuild, new snapshot.
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-doc/devmanual/devmanual-0_pre20200207.ebuild')
-rw-r--r--app-doc/devmanual/devmanual-0_pre20200207.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-doc/devmanual/devmanual-0_pre20200207.ebuild b/app-doc/devmanual/devmanual-0_pre20200207.ebuild
new file mode 100644
index 000000000000..5146b9288cc5
--- /dev/null
+++ b/app-doc/devmanual/devmanual-0_pre20200207.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="The Gentoo Development Guide"
+HOMEPAGE="https://devmanual.gentoo.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/devmanual.git"
+else
+ SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+ S="${WORKDIR}/${PN}"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE="+offline"
+
+BDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ gnome-base/librsvg
+ media-fonts/open-sans"
+
+PATCHES=( "${FILESDIR}"/${PN}-eclasses.patch )
+
+src_compile() {
+ emake OFFLINE=$(usex offline 1 0)
+}
+
+src_install() {
+ emake OFFLINE=$(usex offline 1 0) \
+ DESTDIR="${D}" \
+ htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ local DOC_CONTENTS="In order to browse the Gentoo Development Guide in
+ offline mode, point your browser to the following url:
+ file://${EPREFIX}/usr/share/doc/${PF}/html/index.html"
+ if ! has_version app-doc/eclass-manpages; then
+ DOC_CONTENTS+="\\n\\nThe offline version of the devmanual does not
+ include the documentation for the eclasses. If you need it,
+ then emerge app-doc/eclass-manpages."
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}