summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2019-01-05 23:34:05 +0000
committerUlrich Müller <ulm@gentoo.org>2019-06-23 20:10:00 +0200
commite88a07653f941c6326cce8d45fccb654eaeab1d1 (patch)
treebfae18768270082b126c3f814cf5fc858f72bce3 /app-doc/devmanual/devmanual-9999.ebuild
parentapp-portage/repoman: Remove old version 2.3.14 (diff)
downloadgentoo-e88a07653f941c6326cce8d45fccb654eaeab1d1.tar.gz
gentoo-e88a07653f941c6326cce8d45fccb654eaeab1d1.tar.bz2
gentoo-e88a07653f941c6326cce8d45fccb654eaeab1d1.zip
app-doc/devmanual: Fix assets for offline browsing
Closes: https://bugs.gentoo.org/617724 Closes: https://github.com/gentoo/gentoo/pull/10974 Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com> [sed tweaks converted to patch] Package-Manager: Portage-2.3.67, Repoman-2.3.15 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-doc/devmanual/devmanual-9999.ebuild')
-rw-r--r--app-doc/devmanual/devmanual-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/app-doc/devmanual/devmanual-9999.ebuild b/app-doc/devmanual/devmanual-9999.ebuild
index b71b47820054..8ad5f06a357e 100644
--- a/app-doc/devmanual/devmanual-9999.ebuild
+++ b/app-doc/devmanual/devmanual-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit readme.gentoo-r1
@@ -10,7 +10,7 @@ HOMEPAGE="https://devmanual.gentoo.org/"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/devmanual.git"
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/devmanual.git"
else
SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos"
@@ -18,11 +18,16 @@ fi
LICENSE="CC-BY-SA-3.0"
SLOT="0"
-IUSE=""
+IUSE="+fallback"
-DEPEND="dev-libs/libxslt
+BDEPEND="dev-libs/libxslt
media-gfx/imagemagick[truetype,svg,png]"
+src_prepare() {
+ default
+ use fallback && eapply "${FILESDIR}"/${PN}-fallback.patch
+}
+
src_compile() {
# Imagemagick uses inkscape (if present) to delegate
# svg conversions.