summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-12-14 20:31:16 -0600
committerMatthias Maier <tamiko@gentoo.org>2017-12-14 21:58:05 -0600
commit72c0b85f06e30c53c92a96a9288e0620502611d5 (patch)
tree56ea26bce8519df1c6b3ca4a06e37ba737457c03 /app-doc/doxygen/doxygen-9999.ebuild
parentdev-php/symfony-finder: QA fix for SRC_URI and DESCRIPTION (diff)
downloadgentoo-72c0b85f06e30c53c92a96a9288e0620502611d5.tar.gz
gentoo-72c0b85f06e30c53c92a96a9288e0620502611d5.tar.bz2
gentoo-72c0b85f06e30c53c92a96a9288e0620502611d5.zip
app-doc/doxygen: significantly clean up ebuild
- remove desktop entry setup and inherit old fdo-mime eclass - fix dependencies Closes: https://bugs.gentoo.org/633872 Closes: https://bugs.gentoo.org/625892 Closes: https://bugs.gentoo.org/637200 Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'app-doc/doxygen/doxygen-9999.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild37
1 files changed, 9 insertions, 28 deletions
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index 9f04e7ce861b..607349bff314 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit cmake-utils eutils fdo-mime flag-o-matic python-any-r1
+inherit cmake-utils eutils python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/doxygen/doxygen.git"
@@ -34,10 +34,17 @@ RDEPEND="app-text/ghostscript-gpl
media-libs/freetype
)
doxysearch? ( =dev-libs/xapian-1.2* )
- latex? ( app-text/texlive[extra] )
+ latex? (
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsxextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
qt5? (
dev-qt/qtgui:5
dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
)
sqlite? ( dev-db/sqlite:3 )
"
@@ -118,30 +125,4 @@ src_compile() {
src_install() {
cmake-utils_src_install
-
- if use qt5; then
- doicon "${DISTDIR}/doxywizard.png"
- make_desktop_entry doxywizard "DoxyWizard ${PV}" \
- "/usr/share/pixmaps/doxywizard.png" \
- "Development"
- fi
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-
- elog
- elog "For examples and other goodies, see the source tarball. For some"
- elog "example output, run doxygen on the doxygen source using the"
- elog "Doxyfile provided in the top-level source dir."
- elog
- elog "Disabling the dot USE flag will remove the GraphViz dependency,"
- elog "along with Doxygen's ability to generate diagrams in the docs."
- elog "See the Doxygen homepage for additional helper tools to parse"
- elog "more languages."
- elog
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
}