summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-08-02 01:10:20 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-08-02 01:23:40 -0500
commited2776cacaaabd224c87213b44751a7052c1802a (patch)
treec7df4ec1fc8f9f2f4d0c1ed62a765e79813b48d8 /app-doc/doxygen
parentprofiles: mask glcd lcd driver for app-misc/lcdproc on ppc64 (diff)
downloadgentoo-ed2776cacaaabd224c87213b44751a7052c1802a.tar.gz
gentoo-ed2776cacaaabd224c87213b44751a7052c1802a.tar.bz2
gentoo-ed2776cacaaabd224c87213b44751a7052c1802a.zip
app-doc/doxygen: force emake
Closes: https://bugs.gentoo.org/681070 Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/doxygen-1.8.14-r1.ebuild4
-rw-r--r--app-doc/doxygen/doxygen-1.8.14-r2.ebuild2
-rw-r--r--app-doc/doxygen/doxygen-1.8.15.ebuild2
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild4
4 files changed, 10 insertions, 2 deletions
diff --git a/app-doc/doxygen/doxygen-1.8.14-r1.ebuild b/app-doc/doxygen/doxygen-1.8.14-r1.ebuild
index 3eb0362631e4..7b053f387a93 100644
--- a/app-doc/doxygen/doxygen-1.8.14-r1.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.14-r1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+CMAKE_MAKEFILE_GENERATOR="emake"
+
inherit cmake-utils eutils python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
diff --git a/app-doc/doxygen/doxygen-1.8.14-r2.ebuild b/app-doc/doxygen/doxygen-1.8.14-r2.ebuild
index 4a5c877ce56e..e01da2ff24ba 100644
--- a/app-doc/doxygen/doxygen-1.8.14-r2.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.14-r2.ebuild
@@ -4,6 +4,8 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+CMAKE_MAKEFILE_GENERATOR="emake"
+
inherit cmake-utils eutils python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
diff --git a/app-doc/doxygen/doxygen-1.8.15.ebuild b/app-doc/doxygen/doxygen-1.8.15.ebuild
index d609aec89e6a..ed0edb35d978 100644
--- a/app-doc/doxygen/doxygen-1.8.15.ebuild
+++ b/app-doc/doxygen/doxygen-1.8.15.ebuild
@@ -4,6 +4,8 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+CMAKE_MAKEFILE_GENERATOR="emake"
+
inherit cmake-utils eutils python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index c02d0e50f82a..5fa14ce3f098 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+CMAKE_MAKEFILE_GENERATOR="emake"
+
inherit cmake-utils eutils python-any-r1
if [[ ${PV} = *9999* ]]; then
inherit git-r3