summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2020-12-05 15:51:58 +0100
committerGuilherme Amadio <amadio@gentoo.org>2020-12-05 15:54:11 +0100
commit9055f0c7e98a2c95b9c9a459d7e2385516ca533f (patch)
treece250197889614c9ed53f96ce16267747c1f44b3 /app-doc/geant-docs/geant-docs-4.10.7.ebuild
parentsci-physics/geant-data: version bump to 4.10.7 (diff)
downloadgentoo-9055f0c7e98a2c95b9c9a459d7e2385516ca533f.tar.gz
gentoo-9055f0c7e98a2c95b9c9a459d7e2385516ca533f.tar.bz2
gentoo-9055f0c7e98a2c95b9c9a459d7e2385516ca533f.zip
app-doc/geant-docs: version bump to 4.10.7
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'app-doc/geant-docs/geant-docs-4.10.7.ebuild')
-rw-r--r--app-doc/geant-docs/geant-docs-4.10.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-doc/geant-docs/geant-docs-4.10.7.ebuild b/app-doc/geant-docs/geant-docs-4.10.7.ebuild
new file mode 100644
index 000000000000..56ae17a3ab7e
--- /dev/null
+++ b/app-doc/geant-docs/geant-docs-4.10.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=V$(ver_cut 2-3)
+
+DESCRIPTION="User documentation for Geant4 physics simulation toolkit"
+HOMEPAGE="https://geant4.web.cern.ch/support/user_documentation"
+SRC_DOC="https://geant4-userdoc.web.cern.ch/geant4-userdoc/UsersGuides"
+SRC_URI="
+ ${SRC_DOC}/FAQ/BackupVersions/${MY_PV}/fo/BookFAQ.pdf
+ -> BookFAQ-${PV}.pdf
+ ${SRC_DOC}/ForApplicationDeveloper/BackupVersions/${MY_PV}/fo/BookForApplicationDevelopers.pdf
+ -> BookForApplicationDevelopers-${PV}.pdf
+ ${SRC_DOC}/ForToolkitDeveloper/BackupVersions/${MY_PV}/fo/BookForToolkitDevelopers.pdf
+ -> BookForToolkitDevelopers-${PV}.pdf
+ ${SRC_DOC}/InstallationGuide/BackupVersions/${MY_PV}/fo/Geant4InstallationGuide.pdf
+ -> Geant4InstallationGuide-${PV}.pdf
+ ${SRC_DOC}/IntroductionToGeant4/BackupVersions/${MY_PV}/fo/IntroductionToGeant4.pdf
+ -> IntroductionToGeant4-${PV}.pdf
+ ${SRC_DOC}/PhysicsListGuide/BackupVersions/${MY_PV}/fo/PhysicsListGuide.pdf
+ -> PhysicsListGuide-${PV}.pdf
+ ${SRC_DOC}/PhysicsReferenceManual/BackupVersions/${MY_PV}/fo/PhysicsReferenceManual.pdf
+ -> PhysicsReferenceManual-${PV}.pdf
+"
+
+LICENSE="geant4"
+SLOT="4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${DISTDIR}"
+
+src_install() {
+ local doc
+ for doc in *.pdf; do
+ newdoc ${doc} ${doc/-${PV}};
+ done
+}