summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-01-10 13:58:33 +1100
committerMark Wright <gienah@gentoo.org>2020-01-10 19:43:14 +1100
commitd18700aaccc7a86f87163aeadedb74c60794803d (patch)
tree464405691b6364d254487e73e0c0f6d780752179 /app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
parentacct-user/rstudio-server: Add for sci-mathematics/rstudio (diff)
downloadgentoo-d18700aaccc7a86f87163aeadedb74c60794803d.tar.gz
gentoo-d18700aaccc7a86f87163aeadedb74c60794803d.tar.bz2
gentoo-d18700aaccc7a86f87163aeadedb74c60794803d.zip
app-doc/mathjax-docs: Add for dev-libs/mathjax USE=doc
Bug: https://bugs.gentoo.org/show_bug.cgi?id=526128 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild')
-rw-r--r--app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild b/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
new file mode 100644
index 000000000000..8910e70344b6
--- /dev/null
+++ b/app-doc/mathjax-docs/mathjax-docs-2.7.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit python-utils-r1 vcs-clean
+
+COMMIT="9d711f40638202b02f2154d7f05ea35088ff9388"
+
+DESCRIPTION="MathJax documentation"
+HOMEPAGE="http://www.mathjax.org/"
+SRC_URI="https://github.com/mathjax/MathJax-docs/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+S=${WORKDIR}/MathJax-docs-${COMMIT}
+
+src_prepare() {
+ default
+ egit_clean
+}
+
+src_compile() {
+ build_sphinx "${S}"
+}
+
+src_install() {
+ local DOCS=( README.md )
+ default
+ dosym ${P} /usr/share/doc/${PN}-${SLOT}
+}