summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-12-30 06:34:11 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2020-12-30 06:34:11 -0500
commit0878da0087d322f2aee1b92364d1e2bc2429123e (patch)
tree9c6c8a7bdb107dbbff513a4e4a042b4b7158e191 /app-doc
parentapp-cdr/dvdisaster: Respect CC (diff)
downloadgentoo-0878da0087d322f2aee1b92364d1e2bc2429123e.tar.gz
gentoo-0878da0087d322f2aee1b92364d1e2bc2429123e.tar.bz2
gentoo-0878da0087d322f2aee1b92364d1e2bc2429123e.zip
app-doc/gnucash-docs: Bump to 4.4
Russian translation removed. Bug: https://bugs.gentoo.org/755998 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gnucash-docs/Manifest1
-rw-r--r--app-doc/gnucash-docs/gnucash-docs-4.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-doc/gnucash-docs/Manifest b/app-doc/gnucash-docs/Manifest
index 78b78705394a..9962a1dd0fe0 100644
--- a/app-doc/gnucash-docs/Manifest
+++ b/app-doc/gnucash-docs/Manifest
@@ -1 +1,2 @@
DIST gnucash-docs-4.2.tar.gz 62497632 BLAKE2B 764387cbbc1d072ac3e245a86b78eb484cfa05371dcf4c17d0441bf08e00f85523975c50a88ecde24e9d949572228a723d53fcce7df397553b0e50145be28686 SHA512 e54082dcd7f92d7ca3f31cea5968ecd4167dc9e1e12f23d8684af3e2af4c696d8afed3cf477df771bb11da125ee5887d09ead1edff961ca4bedfb58fd61efdf2
+DIST gnucash-docs-4.4.tar.gz 62534210 BLAKE2B 0c3cdc3ccdf1cfb7a54e44dcde9ea10672cb312e6d6e083ae9bb65bc52b044e8559647a8491f6fa762d9bb84c33f22dd9cacb3a862548994bdc7c56b3e634aa9 SHA512 60e34af3fdb144fefc835d6497fd442daad1417c4e40f8b4fd8f66a37cd0cfa1d789aa03de435d4654ee2368a4b85e9b0cfba8eeef61829e0ca190a453a9abdc
diff --git a/app-doc/gnucash-docs/gnucash-docs-4.4.ebuild b/app-doc/gnucash-docs/gnucash-docs-4.4.ebuild
new file mode 100644
index 000000000000..870c2811c7ca
--- /dev/null
+++ b/app-doc/gnucash-docs/gnucash-docs-4.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools optfeature
+
+DESCRIPTION="Documentation package for GnuCash"
+HOMEPAGE="http://www.gnucash.org/"
+SRC_URI="https://github.com/Gnucash/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 FDL-1.1"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+LOCALES=( de it ja pt )
+IUSE="${LOCALES[*]/#/l10n_}"
+
+DEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ app-text/rarian
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local doc_type my_lang
+
+ for doc_type in help guide; do
+ for my_lang in C ${L10N}; do
+ case $my_lang in
+ # Both help and guides translated
+ C|de|it|pt) ;;
+ ja) # Only guides translated
+ if [[ ${doc_type} = "help" ]] ; then
+ elog "Help documentation hasn't been translated for $my_lang"
+ elog "Will do English instead."
+ continue
+ fi
+ ;;
+ *)
+ die "Invalid locale: $my_lang"
+ ;;
+ esac
+
+ emake -C "${doc_type}/${my_lang}" DESTDIR="${D}" install
+ done
+ done
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "You need dev-java/fop to generate pdf files." dev-java/fop
+ optfeature "You need gnome-extra/yelp to view the docs." gnome-extra/yelp
+}