summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-24 18:13:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-24 18:18:56 +0200
commit2db603bbf058442268a38201f5cb15d9de959a94 (patch)
treede5e1fa4e8dfa14b7e17e080ee57ad1b92d120eb /app-doc
parentdev-lang/python: Bump to 3.10.13 (diff)
downloadgentoo-2db603bbf058442268a38201f5cb15d9de959a94.tar.gz
gentoo-2db603bbf058442268a38201f5cb15d9de959a94.tar.bz2
gentoo-2db603bbf058442268a38201f5cb15d9de959a94.zip
app-doc/python-docs: Bump to 3.10.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/python-docs/Manifest1
-rw-r--r--app-doc/python-docs/python-docs-3.10.13.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/python-docs/Manifest b/app-doc/python-docs/Manifest
index e5b25b7fa839..e9808152cb87 100644
--- a/app-doc/python-docs/Manifest
+++ b/app-doc/python-docs/Manifest
@@ -1,5 +1,6 @@
DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709641e0844c42e924262d6ee21a55e515aaf4d023bf394681bab780ab83998de9f409685e2d5870506810432145acc6422eff9d SHA512 db39390577ec86f13c9b6b57c01cba36fe9fd89092a773dc94f1a6a19d912759d097c4d80e765d3657b572abc731c1da9e7b4cd4c38065cd444606b906744abe
DIST python-3.10.12-docs-html.tar.bz2 7433462 BLAKE2B 8078af52a2ee8c2f308a30a2ceed2241080fa790c9e581809c85a5abb399522ae90b1126612b4cc1ce46d049e91b8d79d05e29337d55473c491dad1a2b80be5c SHA512 e6b02bdce8c96fa168f0faa2435773496ddf761072c93c2944870bafc0ddb49afea5fad73cf6000119bc01435fa558a19f70e5abebe1a51e7c9547911aa336fb
+DIST python-3.10.13-docs-html.tar.bz2 7429989 BLAKE2B 7ddd11dbc4012cebf2f5980653b761ee35b986b75d96d582800f84e4c371aee4b82fcc2001c744e7f14991e766b0930a9ef4cb46869544e0aa403e513c4bd418 SHA512 be2cb6a2ece7849b1c259e9d86b7cf5e2a91c30a976b155c4055fc229d35a1762a90321a6227e890b6d5be51ab3377b9059b9662eed683933ec676fc2dc5f9a9
DIST python-3.11.4-docs-html.tar.bz2 7831799 BLAKE2B 81245e6f47f9179ac8fcf8c1e8a2d6f28c2f7924984d541af71684b4a00896ab38280150a04b8ed051a62ee957cd7613fe28ba79c23624b9bf00d1e7587d7e6c SHA512 b00fa45da239d804e12dcfd5f248b0feb060c2c6e7003913ba6b29a5d198e439dd59ac779c0e4417ccfa90f3654dd3233804974f47efda4fb5891fbe1c6a9f6f
DIST python-3.8.17-docs-html.tar.bz2 6737444 BLAKE2B f6f9a4da13837ecede50eb4d2074b1c6d2be616449f81712e3c551d61d56ac0e314aca84dbcae7d07e89d6f316bec5a6d0797fa0b0f8bf98632ff3c0b6ffad06 SHA512 ab29fc066df0edcaf40dab079cf8fcaa68b895da053ce9cf3d8d776510d804ccfb17ba04e5464ed5edaeb938aaac8aa51bba67c7c3dff80f65cc67bd2d902a1a
DIST python-3.9.17-docs-html.tar.bz2 7021842 BLAKE2B 7a5e3426ea47929289078f9fd2c4fc6b833ba172701ebe9d85f6f821d28bc0bbde1cf88fc99807cc9f7031039c10f451280baf3892040b28ad4733c1e53995fb SHA512 900b82f558b08058390d52b18aa2bcee4a8e74fa9555e36fc924c822506c80f002e90d51b1e6263c0dde612937b6d419e76952288ad923ffcca8562c927a8e76
diff --git a/app-doc/python-docs/python-docs-3.10.13.ebuild b/app-doc/python-docs/python-docs-3.10.13.ebuild
new file mode 100644
index 000000000000..2ab918028481
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.10.13.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}