summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-29 08:50:46 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-29 09:16:46 +0100
commit73e1b27f7550812417d63488c510c28c07b76589 (patch)
tree7340211500185dbd9cf8977520e39aef1dfb93a4 /app-doc
parentdev-ruby/rash_alt: add ruby26 (diff)
downloadgentoo-73e1b27f7550812417d63488c510c28c07b76589.tar.gz
gentoo-73e1b27f7550812417d63488c510c28c07b76589.tar.bz2
gentoo-73e1b27f7550812417d63488c510c28c07b76589.zip
app-doc/eclass-manpages: Switch live ebuild to use dedicated repo
Switch the live ebuild to use the dedicated script repository rather than keeping the script in FILESDIR. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-99999999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
index 7dfb0d7e0d2a..a0e75b5e7e24 100644
--- a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
+++ b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
@@ -16,15 +16,20 @@ SLOT="0"
KEYWORDS=""
IUSE=""
+DEPEND="sys-apps/gawk"
+
src_unpack() {
git-r3_fetch
+ git-r3_fetch "https://github.com/mgorny/eclass-to-manpage"
+
git-r3_checkout '' '' '' eclass
+ git-r3_checkout "https://github.com/mgorny/eclass-to-manpage"
}
src_compile() {
- env ECLASSDIR="${S}/eclass" bash "${FILESDIR}"/eclass-to-manpage.sh || die
+ emake ECLASSDIR=eclass
}
src_install() {
- doman *.5
+ emake install ECLASSDIR=eclass DESTDIR="${D}" PREFIX=/usr
}