summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-15 20:56:06 +0000
committerSam James <sam@gentoo.org>2022-05-15 21:00:42 +0000
commit8081b6274bfa519e00d7d4692b39d3e1dde220e0 (patch)
tree8b8823dae56fa8bfe8e618db89211a274ba4befe /app-doc
parentmedia-sound/pulseeffects: fix build with Boost 1.79 (diff)
downloadgentoo-8081b6274bfa519e00d7d4692b39d3e1dde220e0.tar.gz
gentoo-8081b6274bfa519e00d7d4692b39d3e1dde220e0.tar.bz2
gentoo-8081b6274bfa519e00d7d4692b39d3e1dde220e0.zip
app-doc/doxygen: fix build with GCC 12
Closes: https://bugs.gentoo.org/844229 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/doxygen-1.9.4.ebuild1
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch19
2 files changed, 20 insertions, 0 deletions
diff --git a/app-doc/doxygen/doxygen-1.9.4.ebuild b/app-doc/doxygen/doxygen-1.9.4.ebuild
index 925f54421fa8..43bcc5ceeb3c 100644
--- a/app-doc/doxygen/doxygen-1.9.4.ebuild
+++ b/app-doc/doxygen/doxygen-1.9.4.ebuild
@@ -59,6 +59,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.9.4-link_with_pthread.patch"
"${FILESDIR}/${PN}-1.9.1-ignore-bad-encoding.patch"
"${FILESDIR}/${PN}-1.9.1-do_not_force_libcxx.patch"
+ "${FILESDIR}/${P}-gcc12-include.patch"
)
DOCS=( LANGUAGE.HOWTO README.md )
diff --git a/app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch b/app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch
new file mode 100644
index 000000000000..44505e4bed40
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch
@@ -0,0 +1,19 @@
+https://github.com/doxygen/doxygen/commit/5198966c8d5fec89116d025c74934ac03ea511fa
+https://bugs.gentoo.org/844229
+
+From: Dimitri van Heesch <doxygen@gmail.com>
+Date: Fri, 6 May 2022 09:55:16 +0200
+Subject: [PATCH] issue #9312: Build: cache.h:53:14: error: 'exchange' is not a
+ member of 'std'
+
+--- a/src/cache.h
++++ b/src/cache.h
+@@ -19,6 +19,7 @@
+ #include <list>
+ #include <unordered_map>
+ #include <mutex>
++#include <utility>
+ #include <ctype.h>
+
+ /*! Fixed size cache for value type V using keys of type K.
+