summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 17:26:54 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:48 +0100
commit8baf35b467b96ef2a49512a72a123e1a44984a83 (patch)
treead38bc2e4afc70a55767ff46d03164d47d87a5ab /app-doc
parentnet-misc/httptype: update EAPI 5 -> 7 (diff)
downloadgentoo-8baf35b467b96ef2a49512a72a123e1a44984a83.tar.gz
gentoo-8baf35b467b96ef2a49512a72a123e1a44984a83.tar.bz2
gentoo-8baf35b467b96ef2a49512a72a123e1a44984a83.zip
app-doc/psmark: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/psmark/files/psmark-2.1-Makefile-QA.patch4
-rw-r--r--app-doc/psmark/files/psmark-2.1-string.patch4
-rw-r--r--app-doc/psmark/psmark-2.1.ebuild15
3 files changed, 11 insertions, 12 deletions
diff --git a/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch b/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch
index 30a81498bf6d..145fe3a32e8e 100644
--- a/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch
+++ b/app-doc/psmark/files/psmark-2.1-Makefile-QA.patch
@@ -1,5 +1,5 @@
---- Makefile.original 2009-10-04 19:06:09.000000000 -0600
-+++ Makefile 2009-10-04 19:08:25.000000000 -0600
+--- a/Makefile
++++ b/Makefile
@@ -3,14 +3,13 @@
all:
make clean
diff --git a/app-doc/psmark/files/psmark-2.1-string.patch b/app-doc/psmark/files/psmark-2.1-string.patch
index f520f8b5e6de..1d1fb3dfbb57 100644
--- a/app-doc/psmark/files/psmark-2.1-string.patch
+++ b/app-doc/psmark/files/psmark-2.1-string.patch
@@ -1,5 +1,5 @@
---- psmark.c.orig 2006-06-06 23:43:19.000000000 -0700
-+++ psmark.c 2006-06-06 23:44:27.000000000 -0700
+--- a/psmark.c
++++ b/psmark.c
@@ -97,9 +97,9 @@
progname);
fprintf(stderr,"example:\n %s -i test.ps -o output.ps -b 0.4 -s 15 \"vertical label\""
diff --git a/app-doc/psmark/psmark-2.1.ebuild b/app-doc/psmark/psmark-2.1.ebuild
index 001312e4f688..eb216d2e1602 100644
--- a/app-doc/psmark/psmark-2.1.ebuild
+++ b/app-doc/psmark/psmark-2.1.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
MY_PN=${PN}-v
MY_P=${MY_PN}${PV}
-S=${WORKDIR}/${PN}
DESCRIPTION="Prints watermark-like text on any PostScript document"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="http://www.antitachyon.com/download/${MY_P}.tar.gz"
+S="${WORKDIR}"/${PN}
-IUSE=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-string.patch\
- "${FILESDIR}"/${P}-Makefile-QA.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-string.patch
+ "${FILESDIR}"/${P}-Makefile-QA.patch
+)
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"