summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-06 18:13:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-06 18:13:19 +0200
commitd003897717dd1b8c31ac0440ef91bab8e47c9d5e (patch)
tree216ccc4804715ec848b633a1644aea3e37d4bbdd /app-doc
parentdev-lang/python: Bump to 3.8.17 (diff)
downloadgentoo-d003897717dd1b8c31ac0440ef91bab8e47c9d5e.tar.gz
gentoo-d003897717dd1b8c31ac0440ef91bab8e47c9d5e.tar.bz2
gentoo-d003897717dd1b8c31ac0440ef91bab8e47c9d5e.zip
app-doc/python-docs: Bump to 3.8.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/python-docs/Manifest1
-rw-r--r--app-doc/python-docs/python-docs-3.8.17.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/python-docs/Manifest b/app-doc/python-docs/Manifest
index b5bc24627835..3f4031b89f43 100644
--- a/app-doc/python-docs/Manifest
+++ b/app-doc/python-docs/Manifest
@@ -4,5 +4,6 @@ DIST python-3.10.11-docs-html.tar.bz2 7390187 BLAKE2B 02f1cea9a25fbf764d07a90957
DIST python-3.11.2-docs-html.tar.bz2 7779519 BLAKE2B d9e1faa1414b18923c08686097d4d65613768c404f712a8ca104f546938016afe5e47bdec25296db1792f1ec49a11ed9899b062b9fdb24e93b2f60d6f49ae82c SHA512 0a6b54b0e3579f640a78e9255ff60b6b18f36752b8949f0f19e5c2fb84c33775c761bed907fb45dc606e5bc894068086cac4935574e89421bee55e8b2127d7d8
DIST python-3.11.3-docs-html.tar.bz2 7779259 BLAKE2B 4d8530d77df2c93f29f7c6d45c519830806c13a2df0daa651b92157ea0343cc4124e06b88c436fa4ca53c45020bee5395b166438d8ad0a757b6722e609c53792 SHA512 23cf287d2bdcfe03bb36b4f63443dbd9895ff645c418a2bd73e5145d4656b0b16ae432be2bc52a70d71f1912c5da85ebc738c07cf6b209ea7e0d0bb781e4e48f
DIST python-3.8.16-docs-html.tar.bz2 6697934 BLAKE2B 99fb1b8e95c3719b1146e845051fa6b9fbf61fabfdd1fe6d93a44e6a46f4b4e44c9ce0adef89cfdeafc8b67d290adda21d295f492a8f54c069ad86fba4952c0b SHA512 aaffc1f4d56be0ff7fbd35c7ca690d9089f9686d957669852aff1406efad2bee52b2b965ffd652780da6048ff9d89e6bbc421e92588841b89d73af43ad4970fb
+DIST python-3.8.17-docs-html.tar.bz2 6737444 BLAKE2B f6f9a4da13837ecede50eb4d2074b1c6d2be616449f81712e3c551d61d56ac0e314aca84dbcae7d07e89d6f316bec5a6d0797fa0b0f8bf98632ff3c0b6ffad06 SHA512 ab29fc066df0edcaf40dab079cf8fcaa68b895da053ce9cf3d8d776510d804ccfb17ba04e5464ed5edaeb938aaac8aa51bba67c7c3dff80f65cc67bd2d902a1a
DIST python-3.9.16-docs-html.tar.bz2 6965048 BLAKE2B 14d30cf5c444b993409751d17959bc46668d2b6e5be76e10d36adb0b8704a2a3908d829e8aa12d384efab31f8b60b462f711f2fa6adf8bc84fbdfe25e4cbc703 SHA512 38828ca880e3ed84a705dba465430f1b9623fec830662805008847c5d44ce04225ea7c2173d3eb138fd98e134fa2bb9ed84788e2b1d045bf9cf20e78e12d4472
DIST python-3.9.17-docs-html.tar.bz2 7021842 BLAKE2B 7a5e3426ea47929289078f9fd2c4fc6b833ba172701ebe9d85f6f821d28bc0bbde1cf88fc99807cc9f7031039c10f451280baf3892040b28ad4733c1e53995fb SHA512 900b82f558b08058390d52b18aa2bcee4a8e74fa9555e36fc924c822506c80f002e90d51b1e6263c0dde612937b6d419e76952288ad923ffcca8562c927a8e76
diff --git a/app-doc/python-docs/python-docs-3.8.17.ebuild b/app-doc/python-docs/python-docs-3.8.17.ebuild
new file mode 100644
index 000000000000..2ab918028481
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.8.17.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}