summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-08 05:43:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-08 05:43:30 +0100
commitd7a9d167feec093f0f590f7cba33614a55e965aa (patch)
treec7aa6818dda75e5bda34f1574b7594ec16222993 /app-doc
parentdev-lang/python: Bump to 3.12.1 (diff)
downloadgentoo-d7a9d167feec093f0f590f7cba33614a55e965aa.tar.gz
gentoo-d7a9d167feec093f0f590f7cba33614a55e965aa.tar.bz2
gentoo-d7a9d167feec093f0f590f7cba33614a55e965aa.zip
app-doc/python-docs: Bump to 3.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/python-docs/Manifest1
-rw-r--r--app-doc/python-docs/python-docs-3.12.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/python-docs/Manifest b/app-doc/python-docs/Manifest
index c9d24420ad36..1dba01e5ffe8 100644
--- a/app-doc/python-docs/Manifest
+++ b/app-doc/python-docs/Manifest
@@ -3,5 +3,6 @@ DIST python-3.10.13-docs-html.tar.bz2 7429989 BLAKE2B 7ddd11dbc4012cebf2f5980653
DIST python-3.11.6-docs-html.tar.bz2 7881012 BLAKE2B b20cb04dc32d6eacc904aaf3505a919c6a17dce9105899632571574e734c42693ce5f469bb5f2194bcc16eb4458b6df382c5b4fd24b398f21660c6388b87702a SHA512 a0b118ea3d8f17e5c0a4abec353bc8fd04603db2da51375272e164f8c93be7e3a992eaac3d256a9d05c2db26f830e4b4add40cdb2e1108b936ff4d358cbbb40c
DIST python-3.11.7-docs-html.tar.bz2 7855621 BLAKE2B da23f6fc60a47b0796de1b18190922110383ec6185a76e074608f4c1f18c38b89deefd31f63bcf6ce6f82f1731ef68177b209cc1f6c7145f391d48e8fc79ce6d SHA512 6fe0e7d86af549b0f8c59dd84d90f403ed4e5adee61289fe194d788305059ad492265cdb7b8185030f4f872eb40b2311d6a9250a7343edafa75d318d1dfcf864
DIST python-3.12.0-docs-html.tar.bz2 8200382 BLAKE2B e322d9c18a5a0af4b17ab7a670def1e6aa8f3022d37bd190d49bef1780a71371c6abcf5d9cf81b22a08d4115857e3caa6e8200bbf9b2f5f486f13cbef7366eac SHA512 4fa12af1d1280455063e7c37b479136483478296bcc99302b0bdd4696a84cee82456d1de37cc378fede97f3681bc75ffa535034da5bb76e86d01cb283c425733
+DIST python-3.12.1-docs-html.tar.bz2 8189226 BLAKE2B 6382c00670872615910e3c645f24872b6417227b172b18fc3f8b3dd3fadb1444056ed0c07088b21fe6ae91f71c7d295aac8031cda48e2be8e39bf8c4b366ea18 SHA512 605085ebdac199dfcaf39e909c69cea0c2247aa90dface5c8192312dc2f228ee4ece61eb905e9557e7d1786d338c318eee6a780f6398f07ba4db7d50c4e84bb2
DIST python-3.8.18-docs-html.tar.bz2 6729312 BLAKE2B 431b8d5029d09fc2f54fdc998799298ccb6571a68c735320c95469a81e62bc7c2a9ec0ec11caa9886ad6a2d643b8d715e6866c398ec153d101b16efb85cda656 SHA512 80bdbec04355644f4b114e74da3334b4980d783a52ac8c999ede72f39b6137d94f1aaca248a386cfa02d778a10bdd7919ad82932f0aa000b16c102c8cee67e52
DIST python-3.9.18-docs-html.tar.bz2 7023072 BLAKE2B 92273a711cc8c2a35104f7c35bdca50ee0e9794c72aa14e9c4e613298dd6f2ecebbe977a35f1520a8585f1ea3112e8ea8e477c0e3503b025b6cec875fe40033e SHA512 d123266c72db81703c386dc0d436243a36996c39cde382939cebea31ff7a0c049470daa27efc34a3a0d55310bc6fe489ba01572ca961f67ba7a098038f2cb5af
diff --git a/app-doc/python-docs/python-docs-3.12.1.ebuild b/app-doc/python-docs/python-docs-3.12.1.ebuild
new file mode 100644
index 000000000000..2ab918028481
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.12.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}