summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-05-10 18:38:53 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-05-10 18:42:44 +0900
commit4eaf9db562dc96352ae999ffef3d8c6aa6a3222f (patch)
treed5c3eae003d98dee6ee4590d93cac653c7bb6f22 /app-editors/aee
parentapp-editors/aee: update to EAPI 7 (diff)
downloadgentoo-4eaf9db562dc96352ae999ffef3d8c6aa6a3222f.tar.gz
gentoo-4eaf9db562dc96352ae999ffef3d8c6aa6a3222f.tar.bz2
gentoo-4eaf9db562dc96352ae999ffef3d8c6aa6a3222f.zip
app-editors/aee: fix build with >=sys-devel/gcc-10
Closes: https://bugs.gentoo.org/708720 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-editors/aee')
-rw-r--r--app-editors/aee/aee-2.2.15b.ebuild1
-rw-r--r--app-editors/aee/aee-2.2.21.ebuild1
-rw-r--r--app-editors/aee/files/aee-gcc-10.patch44
3 files changed, 46 insertions, 0 deletions
diff --git a/app-editors/aee/aee-2.2.15b.ebuild b/app-editors/aee/aee-2.2.15b.ebuild
index 9c78a5318b8a..56d77568f79b 100644
--- a/app-editors/aee/aee-2.2.15b.ebuild
+++ b/app-editors/aee/aee-2.2.15b.ebuild
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-ae-location.patch
"${FILESDIR}"/${PN}-Wformat-security.patch
+ "${FILESDIR}"/${PN}-gcc-10.patch
)
DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
diff --git a/app-editors/aee/aee-2.2.21.ebuild b/app-editors/aee/aee-2.2.21.ebuild
index b6b2341baafc..c6c40f9b2147 100644
--- a/app-editors/aee/aee-2.2.21.ebuild
+++ b/app-editors/aee/aee-2.2.21.ebuild
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-ae-location.patch
"${FILESDIR}"/${PN}-Wformat-security.patch
+ "${FILESDIR}"/${PN}-gcc-10.patch
)
DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
diff --git a/app-editors/aee/files/aee-gcc-10.patch b/app-editors/aee/files/aee-gcc-10.patch
new file mode 100644
index 000000000000..c8747099e588
--- /dev/null
+++ b/app-editors/aee/files/aee-gcc-10.patch
@@ -0,0 +1,44 @@
+--- a/Xcurse.c
++++ b/Xcurse.c
+@@ -37,6 +37,8 @@
+
+ extern int eightbit;
+
++struct _line *top_of_win;
++
+ static WINDOW *virtual_scr;
+ WINDOW *curscr;
+ WINDOW *stdscr;
+--- a/Xcurse.h
++++ b/Xcurse.h
+@@ -132,7 +132,7 @@
+ int number;
+ };
+
+-struct _line *top_of_win;
++extern struct _line *top_of_win;
+
+ typedef struct WIND {
+ int SR; /* starting row */
+--- a/new_curse.c
++++ b/new_curse.c
+@@ -85,6 +85,8 @@
+ #endif
+
+
++struct _line *top_of_win;
++
+ WINDOW *curscr;
+ static WINDOW *virtual_scr;
+ WINDOW *stdscr;
+--- a/new_curse.h
++++ b/new_curse.h
+@@ -161,7 +161,7 @@
+ int number;
+ };
+
+-struct _line *top_of_win;
++extern struct _line *top_of_win;
+
+ typedef struct WIND {
+ int SR; /* starting row */