summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/bvi/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/bvi/files')
-rw-r--r--app-editors/bvi/files/bvi-1.3.2-fix-buffer-overflow.patch22
-rw-r--r--app-editors/bvi/files/bvi-1.3.2-tinfo.patch35
2 files changed, 57 insertions, 0 deletions
diff --git a/app-editors/bvi/files/bvi-1.3.2-fix-buffer-overflow.patch b/app-editors/bvi/files/bvi-1.3.2-fix-buffer-overflow.patch
new file mode 100644
index 000000000000..e3ebaa3d1295
--- /dev/null
+++ b/app-editors/bvi/files/bvi-1.3.2-fix-buffer-overflow.patch
@@ -0,0 +1,22 @@
+diff --git a/edit.c b/edit.c
+index 328a0cd..3cf6572 100644
+--- a/edit.c
++++ b/edit.c
+@@ -42,7 +42,7 @@ char contru[][4] = {"NUL", "SOH", "STX", "ETX", "EOT", "ENQ", "ACK", "BEL",
+ "CAN", " EM", "SUB", "ESC", " FS", " GS", " RS", " US",
+ "DEL" };
+ char tmpbuf[10];
+-char linbuf[256];
++char linbuf[16384];
+
+ static char getcbuff[BUFFER];
+ static char *getcnext = NULL;
+@@ -492,7 +492,7 @@ printline(mempos, scpos)
+ *(string + print_pos) = '.';
+ }
+ *(string + Anzahl) = '\0';
+- strcat(linbuf, string);
++ strncat(linbuf, string, sizeof(linbuf) - strlen(linbuf) - 1);
+ mvaddstr(scpos, 0, linbuf);
+ }
+
diff --git a/app-editors/bvi/files/bvi-1.3.2-tinfo.patch b/app-editors/bvi/files/bvi-1.3.2-tinfo.patch
new file mode 100644
index 000000000000..b00c88811507
--- /dev/null
+++ b/app-editors/bvi/files/bvi-1.3.2-tinfo.patch
@@ -0,0 +1,35 @@
+diff --git a/configure.in b/configure.in
+index 68076d8..81da696 100644
+--- a/configure.in
++++ b/configure.in
+@@ -58,17 +58,19 @@ AC_ARG_WITH(ncurses,
+ fi
+ ])
+
+-AC_CHECK_HEADER(ncurses.h,
+- AC_CHECK_LIB(ncurses, initscr,
+- AC_DEFINE(HAVE_NCURSES_H) LIBS="${LIBS} -lncurses",
+- AC_CHECK_LIB(curses, initscr,
+- AC_DEFINE(HAVE_CURSES_H) LIBS="${LIBS} -lcurses",
+- AC_MSG_ERROR([bvi requires the curses library]))),
+- AC_CHECK_HEADER(curses.h,
+- AC_CHECK_LIB(curses, initscr,
+- AC_DEFINE(HAVE_CURSES_H) LIBS="${LIBS} -lcurses",
+- AC_MSG_ERROR([bvi requires the curses library])),
+- AC_MSG_ERROR([bvi requires the curses library])))
++AC_CHECK_HEADER([ncurses.h],[
++ AC_SEARCH_LIBS([initscr], [ncurses],[
++ AC_DEFINE(HAVE_NCURSES_H)
++ AC_SEARCH_LIBS([tputs], [tinfo])], [
++ AC_SEARCH_LIBS([initscr], [curses],[
++ AC_DEFINE(HAVE_CURSES_H)
++ AC_SEARCH_LIBS([tputs], [tinfo])],[
++ AC_MSG_ERROR([bvi requires the curses library])])])],[
++ AC_CHECK_HEADER([curses.h],[
++ AC_SEARCH_LIBS([initscr], [curses], [
++ AC_DEFINE(HAVE_CURSES_H)],[
++ AC_MSG_ERROR([bvi requires the curses library])])],[
++ AC_MSG_ERROR([bvi requires the curses library])])])
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ dnl AC_TYPE_SIZE_T