summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-14 23:50:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-15 00:01:53 +0100
commit33ee4bc3f5d7efb6cf02062ce5b9226b597ab691 (patch)
tree113fecf601446de7597707d2edee79bd4d7e8f54 /app-editors/dhex/dhex-0.69.ebuild
parentx11-wm/openbox: Fix IUSE=-xdg w/o python, drop 'static-libs', py39 (diff)
downloadgentoo-33ee4bc3f5d7efb6cf02062ce5b9226b597ab691.tar.gz
gentoo-33ee4bc3f5d7efb6cf02062ce5b9226b597ab691.tar.bz2
gentoo-33ee4bc3f5d7efb6cf02062ce5b9226b597ab691.zip
app-editors/dhex: 0.69 version bump, EAPI-7 bump, https
2019-01-19: 0.69: this will be the final release of dhex 0.6x. I fixed a bug which caused the terminal to be broken. And added the functionality to start the hexcal from the commandline (-x). Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/dhex/dhex-0.69.ebuild')
-rw-r--r--app-editors/dhex/dhex-0.69.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/dhex/dhex-0.69.ebuild b/app-editors/dhex/dhex-0.69.ebuild
new file mode 100644
index 000000000000..01e5fc5f6c32
--- /dev/null
+++ b/app-editors/dhex/dhex-0.69.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${PN}_${PV}
+inherit toolchain-funcs
+
+DESCRIPTION="ncurses-based hex-editor with diff mode"
+HOMEPAGE="https://www.dettus.net/dhex/"
+SRC_URI="https://www.dettus.net/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_install() {
+ dobin dhex
+ dodoc README.txt
+ doman dhex.1 dhex_markers.5 dhex_searchlog.5 dhexrc.5
+}