summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-08-23 19:07:20 +0200
committerUlrich Müller <ulm@gentoo.org>2018-08-23 19:08:38 +0200
commit400e53e8538ed494cd0f12661abe0e40b95f3b58 (patch)
tree897f7e53dacdc81d412d22f528af5b89ef12b595 /app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild
parentapp-editors/emacs: Reorganise gtk* flags. (diff)
downloadgentoo-400e53e8538ed494cd0f12661abe0e40b95f3b58.tar.gz
gentoo-400e53e8538ed494cd0f12661abe0e40b95f3b58.tar.bz2
gentoo-400e53e8538ed494cd0f12661abe0e40b95f3b58.zip
app-editors/emacs-vcs: Reorganise gtk* flags.
As discussed with leio in #gentoo-dev and in #gentoo-qa. - USE="gtk -gtk2" for GTK+ version 3, - USE="gtk gtk2" for GTK+ version 2, - USE="-gtk" for no GTK+ (the "gtk2" flag has no effect). Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild b/app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild
index ee8f5f2ac3c2..c5898b1c2dd7 100644
--- a/app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild
@@ -28,7 +28,7 @@ HOMEPAGE="https://www.gnu.org/software/emacs/"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="27"
-IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif gpm gsettings gtk +gtk3 gzip-el imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif gpm gsettings gtk gtk2 gzip-el imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
REQUIRED_USE="?? ( aqua X )"
RESTRICT="test"
@@ -81,14 +81,13 @@ RDEPEND="sys-libs/ncurses:0=
)
)
gtk? (
- xwidgets? (
- net-libs/webkit-gtk:4=
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? (
x11-libs/gtk+:3
- x11-libs/libXcomposite
- )
- !xwidgets? (
- gtk3? ( x11-libs/gtk+:3 )
- !gtk3? ( x11-libs/gtk+:2 )
+ xwidgets? (
+ net-libs/webkit-gtk:4=
+ x11-libs/libXcomposite
+ )
)
)
!gtk? (
@@ -211,11 +210,12 @@ src_configure() {
recommended that you compile Emacs with the Athena/Lucid or the
Motif toolkit instead.
EOF
- if use xwidgets; then
- myconf+=" --with-x-toolkit=gtk3 --with-xwidgets"
+ if use gtk2; then
+ myconf+=" --with-x-toolkit=gtk2 --without-xwidgets"
+ use xwidgets && ewarn \
+ "USE flag \"xwidgets\" has no effect if \"gtk2\" is set."
else
- myconf+=" --with-x-toolkit=$(usex gtk3 gtk3 gtk2)"
- myconf+=" --without-xwidgets"
+ myconf+=" --with-x-toolkit=gtk3 $(use_with xwidgets)"
fi
for f in motif Xaw3d athena; do
use ${f} && ewarn \